On Tue, Jul 06, 2021, Paolo Bonzini wrote: > On 03/07/21 00:04, isaku.yamahata@xxxxxxxxx wrote: > > +static inline u64 tdh_mng_addcx(hpa_t tdr, hpa_t addr) > > +{ > > + return seamcall(TDH_MNG_ADDCX, addr, tdr, 0, 0, 0, NULL); > > +} > > + > > Since you have wrappers anyway, I don't like having an extra macro level > just to remove the SEAMCALL_ prefix. It messes up editors that look up the > symbols. True. On the other hand, prefixing SEAMCALL_ over and over is tedious and adds a lot of noise. What if we drop SEAMCALL_ from the #defines? The prefix made sense when there was no additional namespace, e.g. instead of having a bare TDCREATE, but that's mostly a non-issue now that all the SEAMCALLs are namespaced with TDH_.