On 6/21/21 12:10 PM, Thomas Huth wrote: > On 20/05/2021 11.47, Janosch Frank wrote: >> Snippets can be used to easily write and run guest (SIE) tests. >> The snippet is linked into the test binaries and can therefore be >> accessed via a ptr. >> >> Signed-off-by: Janosch Frank <frankja@xxxxxxxxxxxxx> >> --- >> .gitignore | 2 ++ >> s390x/Makefile | 28 ++++++++++++++++++--- >> s390x/snippets/c/cstart.S | 13 ++++++++++ >> s390x/snippets/c/flat.lds | 51 +++++++++++++++++++++++++++++++++++++++ >> 4 files changed, 91 insertions(+), 3 deletions(-) >> create mode 100644 s390x/snippets/c/cstart.S >> create mode 100644 s390x/snippets/c/flat.lds >> >> diff --git a/.gitignore b/.gitignore >> index 784cb2dd..29d3635b 100644 >> --- a/.gitignore >> +++ b/.gitignore >> @@ -22,3 +22,5 @@ cscope.* >> /api/dirty-log >> /api/dirty-log-perf >> /s390x/*.bin >> +/s390x/snippets/*/*.bin >> +/s390x/snippets/*/*.gbin >> diff --git a/s390x/Makefile b/s390x/Makefile >> index 8de926ab..fe267011 100644 >> --- a/s390x/Makefile >> +++ b/s390x/Makefile >> @@ -75,11 +75,33 @@ OBJDIRS += lib/s390x >> asmlib = $(TEST_DIR)/cstart64.o $(TEST_DIR)/cpu.o >> >> FLATLIBS = $(libcflat) >> -%.elf: %.o $(FLATLIBS) $(SRCDIR)/s390x/flat.lds $(asmlib) >> + >> +SNIPPET_DIR = $(TEST_DIR)/snippets >> + >> +# C snippets that need to be linked >> +snippets-c = >> + >> +# ASM snippets that are directly compiled and converted to a *.gbin >> +snippets-a = > > Could you please call this snippets-s instead of ...-a ? The -a suffix looks > like an archive to me otherwise. Sure > >> +snippets = $(snippets-a)$(snippets-c) > > Shouldn't there be a space between the two? Yes, already fixed that a long while ago I thought I had sent out a new version already, maybe that was an illusion as I can't seem to find it right now. > >> +snippets-o += $(patsubst %.gbin,%.o,$(snippets)) >> + >> +$(snippets-a): $(snippets-o) $(FLATLIBS) >> + $(OBJCOPY) -O binary $(patsubst %.gbin,%.o,$@) $@ >> + $(OBJCOPY) -I binary -O elf64-s390 -B "s390:64-bit" $@ $@ >> + >> +$(snippets-c): $(snippets-o) $(SNIPPET_DIR)/c/cstart.o $(FLATLIBS) >> + $(CC) $(LDFLAGS) -o $@ -T $(SNIPPET_DIR)/c/flat.lds \ >> + $(filter %.o, $^) $(FLATLIBS) >> + $(OBJCOPY) -O binary $@ $@ >> + $(OBJCOPY) -I binary -O elf64-s390 -B "s390:64-bit" $@ $@ >> + >> +%.elf: $(snippets) %.o $(FLATLIBS) $(SRCDIR)/s390x/flat.lds $(asmlib) >> $(CC) $(CFLAGS) -c -o $(@:.elf=.aux.o) \ >> $(SRCDIR)/lib/auxinfo.c -DPROGNAME=\"$@\" >> $(CC) $(LDFLAGS) -o $@ -T $(SRCDIR)/s390x/flat.lds \ >> - $(filter %.o, $^) $(FLATLIBS) $(@:.elf=.aux.o) >> + $(filter %.o, $^) $(FLATLIBS) $(snippets) $(@:.elf=.aux.o) > > Does this link the snippets into all elf files? ... wouldn't it be better to > restrict it somehow to the files that really need them? Yes it does. I'd like to avoid having to specify a makefile rule for every test that uses snippets as we already have more than the mvpg one in the queue. So I'm having Steffen looking into a solution for this problem. My first idea was to bring the used snippets into the unittests.cfg but I disliked that we then would have compile instructions in another file. Maybe there's a way to include that into the makefile in a clever way? > >> $(RM) $(@:.elf=.aux.o) >> @chmod a-x $@ >> >> @@ -93,7 +115,7 @@ FLATLIBS = $(libcflat) >> $(GENPROTIMG) --host-key-document $(HOST_KEY_DOCUMENT) --no-verify --image $< -o $@ >> >> arch_clean: asm_offsets_clean >> - $(RM) $(TEST_DIR)/*.{o,elf,bin} $(TEST_DIR)/.*.d lib/s390x/.*.d >> + $(RM) $(TEST_DIR)/*.{o,elf,bin} $(SNIPPET_DIR)/c/*.{o,elf,bin,gbin} $(SNIPPET_DIR)/.*.d $(TEST_DIR)/.*.d lib/s390x/.*.d >> >> generated-files = $(asm-offsets) >> $(tests:.elf=.o) $(asmlib) $(cflatobjs): $(generated-files) >> diff --git a/s390x/snippets/c/cstart.S b/s390x/snippets/c/cstart.S >> new file mode 100644 >> index 00000000..02a3338b >> --- /dev/null >> +++ b/s390x/snippets/c/cstart.S >> @@ -0,0 +1,13 @@ >> +#include <asm/sigp.h> >> + >> +.section .init >> + .globl start >> +start: >> + /* XOR all registers with themselves to clear them fully. */ >> + .irp i, 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15 >> + xgr \i,\i >> + .endr >> + /* 0x3000 is the stack page for now */ >> + lghi %r15, 0x4000 >> + brasl %r14, main >> + sigp %r1, %r0, SIGP_STOP > > I think you should clear r0 before using it here? Right. will fix > > Thomas >