On 18.06.2021 16:35, Stefano Garzarella wrote: > vsock_has_data() is used only by STREAM and SEQPACKET sockets, > so let's rename it to vsock_connectible_has_data(), using the same > nomenclature (connectible) used in other functions after the > introduction of SEQPACKET. > > Signed-off-by: Stefano Garzarella <sgarzare@xxxxxxxxxx> > --- > net/vmw_vsock/af_vsock.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/net/vmw_vsock/af_vsock.c b/net/vmw_vsock/af_vsock.c > index 67954afef4e1..de8249483081 100644 > --- a/net/vmw_vsock/af_vsock.c > +++ b/net/vmw_vsock/af_vsock.c > @@ -860,7 +860,7 @@ s64 vsock_stream_has_data(struct vsock_sock *vsk) > } > EXPORT_SYMBOL_GPL(vsock_stream_has_data); > > -static s64 vsock_has_data(struct vsock_sock *vsk) > +static s64 vsock_connectible_has_data(struct vsock_sock *vsk) > { > struct sock *sk = sk_vsock(vsk); > > @@ -1880,7 +1880,7 @@ static int vsock_wait_data(struct sock *sk, struct wait_queue_entry *wait, > err = 0; > transport = vsk->transport; > > - while ((data = vsock_has_data(vsk)) == 0) { > + while ((data = vsock_connectible_has_data(vsk)) == 0) { > prepare_to_wait(sk_sleep(sk), wait, TASK_INTERRUPTIBLE); > > if (sk->sk_err != 0 || LGTM