On Wed, May 19, 2021 at 09:05:37AM +0530, Anup Patel wrote: > +void kvm_riscv_stage2_free_pgd(struct kvm *kvm) > +{ > + /* TODO: */ > +} > + I was disappointed how many stub functions remained at the end of the patchset... It's better to not publish those. How useful is this patchset with the functionality that is implemented currently? > +int kvm_arch_init_vm(struct kvm *kvm, unsigned long type) > +{ > + int r; > + > + r = kvm_riscv_stage2_alloc_pgd(kvm); > + if (r) > + return r; > + > + return 0; > +} Half the code uses "int ret;" and half uses "int r;". Make everything int ret. regards, dan carpenter