On Tue, May 11, 2021, Krish Sadhukhan wrote: > Move 'nested_run' counter to enter_guest_mode() because, > i) This counter is common to both Intel and AMD and can be incremented > from a common place, > ii) guest mode is a more finer-grained state than the beginning of > nested_svm_vmrun() and nested_vmx_run(). Hooking enter_guest_mode() makes the name a misnomer since it will count cases such as setting nested state and resuming from SMI, neither of which is a nested run in the sense of L1 deliberately choosing to run L2. And while bumping nested_run at the very beginning of VMLAUNCH/VMRESUME/VMRUN is arguably wrong in that it counts _attempts_ instead of successful VM-Enters, it's at least consistent. Moving this to enter_guest_mode() means it's arbitrarily counting VM-Enter that fails late, but not those that fail early. If we really want it to mean "successful VM-Enter", then we should wait until after VM-Enter actual succeeds, and do it only for actual VM-Enter.