On 01/04/21 00:29, Sean Christopherson wrote:
+ if (is_tdp_mmu_enabled(kvm)) {
+ read_lock(&kvm->mmu_lock);
+ kvm_tdp_mmu_zap_all_fast(kvm);
Purely because it exists first, I think we should follow the legacy MMU's
terminology, i.e. kvm_tdp_mmu_zap_obsolete_pages().
It's a bit different, obsolete pages in kvm_zap_obsolete_pages have an
old mmu_valid_gen. They are not invalid, so it is inaccurate to talk
about obsolete pages in the context of the TDP MMU. But I agree that
the function should be renamed.
Paolo