On Mon, Oct 05, 2009 at 04:03:22PM -0300, Lucas Meneghel Rodrigues wrote: > Hi Yolkfull! I've checked your patch, but it turns out that the comma > is valid syntax for the logging module. By any chance you actually had > an error with it? Hi Lucas, I just checked, yes it's valid syntax for this module. Before this I met a traceback during running autotest and it indicated this line around,thus I doubt about this by mistake. Sorry for confusing. ;-) But I found for the variables in logging.debug(),sometimes it use comma to format while sometimes '%' which will drop code readability. Anyway, thanks for checking. > > On Mon, Sep 28, 2009 at 4:45 AM, Yolkfull Chow <yzhou@xxxxxxxxxx> wrote: > > > > Signed-off-by: Yolkfull Chow <yzhou@xxxxxxxxxx> > > --- > > client/tests/kvm/kvm_vm.py | 2 +- > > 1 files changed, 1 insertions(+), 1 deletions(-) > > > > diff --git a/client/tests/kvm/kvm_vm.py b/client/tests/kvm/kvm_vm.py > > index 55220f9..8aeffff 100755 > > --- a/client/tests/kvm/kvm_vm.py > > +++ b/client/tests/kvm/kvm_vm.py > > @@ -406,7 +406,7 @@ class VM: > > self.process.get_output())) > > return False > > > > - logging.debug("VM appears to be alive with PID %d", > > + logging.debug("VM appears to be alive with PID %d" % > > self.process.get_pid()) > > return True > > > > -- > > 1.6.2.5 > > > > _______________________________________________ > > Autotest mailing list > > Autotest@xxxxxxxxxxxxxxx > > http://test.kernel.org/cgi-bin/mailman/listinfo/autotest > > > > > > -- > Lucas > -- > To unsubscribe from this list: send the line "unsubscribe kvm" in > the body of a message to majordomo@xxxxxxxxxxxxxxx > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html