On 22/02/2021 09.57, Janosch Frank wrote:
There are no more users. At the same time remove sw_int_fpc and sw_int_frps plus their asm offsets macros since they are also unused now. Signed-off-by: Janosch Frank <frankja@xxxxxxxxxxxxx> Reviewed-by: Claudio Imbrenda <imbrenda@xxxxxxxxxxxxx> Reviewed-by: Pierre Morel <pmorel@xxxxxxxxxxxxx> --- lib/s390x/asm-offsets.c | 2 -- lib/s390x/asm/arch_def.h | 4 +--- s390x/macros.S | 29 ----------------------------- 3 files changed, 1 insertion(+), 34 deletions(-) diff --git a/lib/s390x/asm-offsets.c b/lib/s390x/asm-offsets.c index 2658b59a..fbea3278 100644 --- a/lib/s390x/asm-offsets.c +++ b/lib/s390x/asm-offsets.c @@ -54,8 +54,6 @@ int main(void) OFFSET(GEN_LC_MCCK_NEW_PSW, lowcore, mcck_new_psw); OFFSET(GEN_LC_IO_NEW_PSW, lowcore, io_new_psw); OFFSET(GEN_LC_SW_INT_GRS, lowcore, sw_int_grs); - OFFSET(GEN_LC_SW_INT_FPRS, lowcore, sw_int_fprs); - OFFSET(GEN_LC_SW_INT_FPC, lowcore, sw_int_fpc); OFFSET(GEN_LC_SW_INT_CRS, lowcore, sw_int_crs); OFFSET(GEN_LC_SW_INT_PSW, lowcore, sw_int_psw); OFFSET(GEN_LC_MCCK_EXT_SA_ADDR, lowcore, mcck_ext_sa_addr); diff --git a/lib/s390x/asm/arch_def.h b/lib/s390x/asm/arch_def.h index b8e9fe40..13e19b8a 100644 --- a/lib/s390x/asm/arch_def.h +++ b/lib/s390x/asm/arch_def.h @@ -103,9 +103,7 @@ struct lowcore { struct psw io_new_psw; /* 0x01f0 */ /* sw definition: save area for registers in interrupt handlers */ uint64_t sw_int_grs[16]; /* 0x0200 */ - uint64_t sw_int_fprs[16]; /* 0x0280 */ - uint32_t sw_int_fpc; /* 0x0300 */ - uint8_t pad_0x0304[0x0308 - 0x0304]; /* 0x0304 */ + uint8_t pad_0x0304[0x0308 - 0x0280]; /* 0x0280 */
Please rename to pad_0x280 now. With that fixed: Reviewed-by: Thomas Huth <thuth@xxxxxxxxxx>