The current 'struct whpx_vcpu' contains the vCPU fields specific to the WHPX accelerator. Rename it as AccelvCPUState. We keep the 'whpx_vcpu' typedef to reduce the amount of code changed. Signed-off-by: Philippe Mathieu-Daudé <philmd@xxxxxxxxxx> --- target/i386/whpx/whpx-all.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/target/i386/whpx/whpx-all.c b/target/i386/whpx/whpx-all.c index 6469e388b6d..f0b3266114d 100644 --- a/target/i386/whpx/whpx-all.c +++ b/target/i386/whpx/whpx-all.c @@ -148,9 +148,9 @@ struct whpx_register_set { WHV_REGISTER_VALUE values[RTL_NUMBER_OF(whpx_register_names)]; }; -typedef struct whpx_vcpu whpx_vcpu; +typedef struct AccelvCPUState whpx_vcpu; -struct whpx_vcpu { +struct AccelvCPUState { WHV_EMULATOR_HANDLE emulator; bool window_registered; bool interruptable; -- 2.26.2