v4 -> v5: 1. The op 'prepare_guest_switch' has been renamed to 'prepare_switch_to_guest'. 2. The following functions were missing the 'static' keyword (reported by kernel test robot <lkp@xxxxxxxxx>): svm_get_cs_db_l_bits svm_tlb_flush_all svm_tlb_flush_current svm_tlb_flush_guest [PATCH 1/5 v5] KVM: x86: Change names of some of the kvm_x86_ops [PATCH 2/5 v5] KVM: SVM: Fill in conforming svm_x86_ops via macro [PATCH 3/5 v5] KVM: nSVM: Fill in conforming svm_nested_ops via macro [PATCH 4/5 v5] KVM: VMX: Fill in conforming vmx_x86_ops via macro [PATCH 5/5 v5] KVM: nVMX: Fill in conforming vmx_nested_ops via macro arch/arm64/include/asm/kvm_host.h | 2 +- arch/mips/include/asm/kvm_host.h | 2 +- arch/powerpc/include/asm/kvm_host.h | 2 +- arch/s390/kvm/kvm-s390.c | 2 +- arch/x86/include/asm/kvm_host.h | 18 +-- arch/x86/kvm/lapic.c | 2 +- arch/x86/kvm/pmu.h | 4 +- arch/x86/kvm/svm/avic.c | 11 +- arch/x86/kvm/svm/nested.c | 20 +-- arch/x86/kvm/svm/pmu.c | 2 +- arch/x86/kvm/svm/sev.c | 4 +- arch/x86/kvm/svm/svm.c | 298 ++++++++++++++++++++---------------- arch/x86/kvm/svm/svm.h | 15 +- arch/x86/kvm/vmx/evmcs.c | 6 +- arch/x86/kvm/vmx/evmcs.h | 4 +- arch/x86/kvm/vmx/nested.c | 37 +++-- arch/x86/kvm/vmx/pmu_intel.c | 2 +- arch/x86/kvm/vmx/posted_intr.c | 6 +- arch/x86/kvm/vmx/posted_intr.h | 4 +- arch/x86/kvm/vmx/vmx.c | 260 +++++++++++++++---------------- arch/x86/kvm/vmx/vmx.h | 2 +- arch/x86/kvm/x86.c | 43 ++---- include/linux/kvm_host.h | 2 +- include/uapi/linux/kvm.h | 6 +- tools/include/uapi/linux/kvm.h | 6 +- virt/kvm/kvm_main.c | 4 +- 26 files changed, 405 insertions(+), 359 deletions(-) Krish Sadhukhan (5): KVM: x86: Change names of some of the kvm_x86_ops functions to make them m ore semantical and readable KVM: SVM: Fill in conforming svm_x86_ops via macro KVM: nSVM: Fill in conforming svm_nested_ops via macro KVM: VMX: Fill in conforming vmx_x86_ops via macro KVM: nVMX: Fill in conforming vmx_nested_ops via macro