This patchset adds code to s390 pci to examine the VFIO_DEVICE_GET_INFO capability chain, looking for capabilities that describe the underlying hardware and features of the passed-through device. The retrieval of this information is done once per function (and for a subset of data, once per function group) and is performed at time of device plug. Some elements provided via the capability chain must still be forced to default values for now to reflect what QEMU actually provides support for. The original work for this feature was done by Pierre Morel. Associated kernel patchset: https://lkml.org/lkml/2020/10/7/813 Tested using a host kernel with/without the VFIO_DEVICE_GET_INFO changes and a QEMU with/without the VFIO_DEVICE_GET_INFO changes to validate VFIO_DEVICE_GET_INFO remains backwards-compatible. Changes since v2: - Added ACKs/RBs (thanks!) - Squashed the first 2 patches, and tried again using by formatting the set with --find-renames / diff.renames. (Thanks Richard and Paolo!) As before, this first patch can be applied separately but is included here for the sake of simplicity. - Copied patch 'vfio: Create shared routine for scanning info capabilities' from the 'Accomodate vfio DMA limiting' set, as it's now needed here too. We can drop it from this set later once the former is applied. - Refresh the linux-header placeholder. Manually omit the qatomic->atomic pvrdma revert for now. - New patch to add a helper function for finding VFIO_DEVICE_GET_INFO capabilities. Depends on 'vfio: Create shared routine for scanning info capabilities' - re-write the last patch to use VFIO_DEVICE_GET_INFO capabilities instead of a vfio device region Matthew Rosato (7): s390x/pci: Move header files to include/hw/s390x vfio: Create shared routine for scanning info capabilities update-linux-headers: Add vfio_zdev.h linux-headers: update against 5.9-rc8 s390x/pci: clean up s390 PCI groups vfio: Add routine for finding VFIO_DEVICE_GET_INFO capabilities s390x/pci: get zPCI function info from host Pierre Morel (3): s390x/pci: create a header dedicated to PCI CLP s390x/pci: use a PCI Group structure s390x/pci: use a PCI Function structure MAINTAINERS | 1 + hw/s390x/meson.build | 1 + hw/s390x/s390-pci-bus.c | 86 ++++++++- hw/s390x/s390-pci-inst.c | 33 ++-- hw/s390x/s390-pci-vfio.c | 197 +++++++++++++++++++++ hw/s390x/s390-virtio-ccw.c | 2 +- hw/vfio/common.c | 31 +++- {hw => include/hw}/s390x/s390-pci-bus.h | 13 ++ .../hw/s390x/s390-pci-clp.h | 123 ++----------- include/hw/s390x/s390-pci-inst.h | 116 ++++++++++++ include/hw/s390x/s390-pci-vfio.h | 19 ++ include/hw/vfio/vfio-common.h | 2 + linux-headers/linux/kvm.h | 6 +- linux-headers/linux/vfio.h | 11 ++ linux-headers/linux/vfio_zdev.h | 78 ++++++++ scripts/update-linux-headers.sh | 2 +- 16 files changed, 575 insertions(+), 146 deletions(-) create mode 100644 hw/s390x/s390-pci-vfio.c rename {hw => include/hw}/s390x/s390-pci-bus.h (96%) rename hw/s390x/s390-pci-inst.h => include/hw/s390x/s390-pci-clp.h (59%) create mode 100644 include/hw/s390x/s390-pci-inst.h create mode 100644 include/hw/s390x/s390-pci-vfio.h create mode 100644 linux-headers/linux/vfio_zdev.h -- 1.8.3.1