Rename vmx/ops.h to vmx/vmx_ops.h, and move VMX's posted interrupt support to dedicated files in preparation for future Trust Domain Extensions (TDX) enabling. These changes are somewhat premature, as full TDX enabling is months away, but the posted interrupts change is (IMO) valuable irrespective of TDX. The value of the vmx_ops.h rename without TDX is debatable. I have no problem deferring the change to the actual TDX series if there are objections. I'm submitting the patch now as getting the rename upstream will save us minor merge conflict pain if there are changes to vmx/ops.h between now and whenever the TDX enabling series comes along. https://software.intel.com/content/www/us/en/develop/articles/intel-trust-domain-extensions.html Sean Christopherson (1): KVM: VMX: Rename ops.h to vmx_ops.h Xiaoyao Li (1): KVM: VMX: Extract posted interrupt support to separate files arch/x86/kvm/Makefile | 3 +- arch/x86/kvm/vmx/posted_intr.c | 332 ++++++++++++++++++++++++++ arch/x86/kvm/vmx/posted_intr.h | 99 ++++++++ arch/x86/kvm/vmx/vmx.c | 321 +------------------------ arch/x86/kvm/vmx/vmx.h | 92 +------ arch/x86/kvm/vmx/{ops.h => vmx_ops.h} | 0 6 files changed, 440 insertions(+), 407 deletions(-) create mode 100644 arch/x86/kvm/vmx/posted_intr.c create mode 100644 arch/x86/kvm/vmx/posted_intr.h rename arch/x86/kvm/vmx/{ops.h => vmx_ops.h} (100%) -- 2.28.0