On 10/09/2020 09.01, Philippe Mathieu-Daudé wrote: > In order to use inclusive terminology, rename "blackhole" > as "(memory)hole". A black hole is a well-known astronomical term, which is simply named that way since it absorbes all light. I doubt that anybody could get upset by this term? > Signed-off-by: Philippe Mathieu-Daudé <philmd@xxxxxxxxxx> > --- > include/hw/pci-host/q35.h | 4 ++-- > hw/pci-host/q35.c | 38 +++++++++++++++++++------------------- > tests/qtest/q35-test.c | 2 +- > 3 files changed, 22 insertions(+), 22 deletions(-) > > diff --git a/include/hw/pci-host/q35.h b/include/hw/pci-host/q35.h > index 070305f83df..0fb90aca18b 100644 > --- a/include/hw/pci-host/q35.h > +++ b/include/hw/pci-host/q35.h > @@ -48,8 +48,8 @@ typedef struct MCHPCIState { > PAMMemoryRegion pam_regions[13]; > MemoryRegion smram_region, open_high_smram; > MemoryRegion smram, low_smram, high_smram; > - MemoryRegion tseg_blackhole, tseg_window; > - MemoryRegion smbase_blackhole, smbase_window; > + MemoryRegion tseg_hole, tseg_window; > + MemoryRegion smbase_hole, smbase_window; Maybe rather use smbase_memhole and tseg_memhole? Thomas