On 9/10/20 9:01 AM, Philippe Mathieu-Daudé wrote: > In order to use inclusive terminology, rename 'slave stream' > as 'sink stream'. > > Signed-off-by: Philippe Mathieu-Daudé <philmd@xxxxxxxxxx> > --- [...] > diff --git a/include/hw/stream.h b/include/hw/stream.h > index ed09e83683d..8ca161991ca 100644 > --- a/include/hw/stream.h > +++ b/include/hw/stream.h > @@ -3,52 +3,52 @@ > > #include "qom/object.h" > > -/* stream slave. Used until qdev provides a generic way. */ > -#define TYPE_STREAM_SLAVE "stream-slave" > +/* stream sink. Used until qdev provides a generic way. */ > +#define TYPE_STREAM_SINK "stream-slave" > > -#define STREAM_SLAVE_CLASS(klass) \ > - OBJECT_CLASS_CHECK(StreamSlaveClass, (klass), TYPE_STREAM_SLAVE) > -#define STREAM_SLAVE_GET_CLASS(obj) \ > - OBJECT_GET_CLASS(StreamSlaveClass, (obj), TYPE_STREAM_SLAVE) > -#define STREAM_SLAVE(obj) \ > - INTERFACE_CHECK(StreamSlave, (obj), TYPE_STREAM_SLAVE) > +#define STREAM_SINK_CLASS(klass) \ > + OBJECT_CLASS_CHECK(StreamSinkClass, (klass), TYPE_STREAM_SINK) > +#define STREAM_SINK_GET_CLASS(obj) \ > + OBJECT_GET_CLASS(StreamSinkClass, (obj), TYPE_STREAM_SINK) > +#define STREAM_SINK(obj) \ > + INTERFACE_CHECK(StreamSink, (obj), TYPE_STREAM_SINK) Hmm being an interface, is it better to name it TYPE_SINK_STREAM?