On Tue, 25 Aug 2020 12:20:36 +0200 Marc Hartmayer <mhartmay@xxxxxxxxxxxxx> wrote: > Use the same test names in the TAP13 output as in the default output > format. This makes the output more consistent. To achieve this, we > need to pass the test name as an argument to the function > `process_test_output`. > > Before this change: > $ ./run_tests.sh > PASS selftest-setup (14 tests) > ... > > vs. > > $ ./run_tests.sh -t > TAP version 13 > ok 1 - selftest: true > ok 2 - selftest: argc == 3 > ... > > After this change: > $ ./run_tests.sh > PASS selftest-setup (14 tests) > ... > > vs. > > $ ./run_tests.sh -t > TAP version 13 > ok 1 - selftest-setup: selftest: true > ok 2 - selftest-setup: selftest: argc == 3 > ... > > While at it, introduce a local variable `kernel` in > `RUNTIME_log_stdout` since this makes the function easier to read. > > Signed-off-by: Marc Hartmayer <mhartmay@xxxxxxxxxxxxx> > --- > run_tests.sh | 15 +++++++++------ > scripts/runtime.bash | 6 +++--- > 2 files changed, 12 insertions(+), 9 deletions(-) Reviewed-by: Cornelia Huck <cohuck@xxxxxxxxxx>