On Mon, 27 Jul 2020 05:54:13 -0400 Janosch Frank <frankja@xxxxxxxxxxxxx> wrote: > Sometimes we need to do cleanup which we don't necessarily want to add > to interrupt.c, so lets add a way to register a cleanup function. s/lets/let's/ > > Signed-off-by: Janosch Frank <frankja@xxxxxxxxxxxxx> > Reviewed-by: Claudio Imbrenda <imbrenda@xxxxxxxxxxxxx> > Reviewed-by: Thomas Huth <thuth@xxxxxxxxxx> > --- > lib/s390x/asm/interrupt.h | 1 + > lib/s390x/interrupt.c | 10 ++++++++++ > 2 files changed, 11 insertions(+) > > diff --git a/lib/s390x/asm/interrupt.h b/lib/s390x/asm/interrupt.h > index 4cfade9..b2a7c83 100644 > --- a/lib/s390x/asm/interrupt.h > +++ b/lib/s390x/asm/interrupt.h > @@ -15,6 +15,7 @@ > #define EXT_IRQ_EXTERNAL_CALL 0x1202 > #define EXT_IRQ_SERVICE_SIG 0x2401 > > +void register_pgm_int_func(void (*f)(void)); > void handle_pgm_int(void); > void handle_ext_int(void); > void handle_mcck_int(void); > diff --git a/lib/s390x/interrupt.c b/lib/s390x/interrupt.c > index 243b9c2..51cc733 100644 > --- a/lib/s390x/interrupt.c > +++ b/lib/s390x/interrupt.c > @@ -16,6 +16,7 @@ > > static bool pgm_int_expected; > static bool ext_int_expected; > +static void (*pgm_int_func)(void); Hm, didn't you want to rename this to pgm_cleanup_func? > static struct lowcore *lc; > > void expect_pgm_int(void) > @@ -51,6 +52,11 @@ void check_pgm_int_code(uint16_t code) > lc->pgm_int_code); > } > > +void register_pgm_int_func(void (*f)(void)) ...then, register_pgm_cleanup_func() would probably be a better name here. > +{ > + pgm_int_func = f; > +} > + > static void fixup_pgm_int(void) > { > switch (lc->pgm_int_code) { > @@ -115,6 +121,10 @@ void handle_pgm_int(void) > } > > pgm_int_expected = false; > + > + if (pgm_int_func) > + return (*pgm_int_func)(); I'd probably use an else branch, but this is fine as well. > + > fixup_pgm_int(); > } >