Re: [PATCH] KVM: x86: Fill in conforming {vmx|svm}_x86_ops and {vmx|svm}_nested_ops via macros

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Krish Sadhukhan <krish.sadhukhan@xxxxxxxxxx> writes:

> There is no functional change. Just the names of the implemented functions in
> KVM and SVM modules have been made conformant to the kvm_x86_ops and
> kvm_x86_nested_ops structures, by using macros. This will help in better
> readability and maintenance of the code.
>
>
> [PATCH] KVM: x86: Fill in conforming {vmx|svm}_x86_ops and
>
> [root@nsvm-sadhukhan linux]# /root/Tools/git-format-patch.sh dcb7fd8
>  arch/x86/include/asm/kvm_host.h |  12 +-
>  arch/x86/kvm/svm/avic.c         |   4 +-
>  arch/x86/kvm/svm/nested.c       |  16 +--
>  arch/x86/kvm/svm/sev.c          |   4 +-
>  arch/x86/kvm/svm/svm.c          | 218 +++++++++++++++++-----------------
>  arch/x86/kvm/svm/svm.h          |   8 +-
>  arch/x86/kvm/vmx/nested.c       |  26 +++--
>  arch/x86/kvm/vmx/nested.h       |   2 +-
>  arch/x86/kvm/vmx/vmx.c          | 238 +++++++++++++++++++-------------------
>  arch/x86/kvm/vmx/vmx.h          |   2 +-
>  arch/x86/kvm/x86.c              |  20 ++--
>  11 files changed, 279 insertions(+), 271 deletions(-)
>
> Krish Sadhukhan (1):
>       KVM: x86: Fill in conforming {vmx|svm}_x86_ops and {vmx|svm}_nested_ops
>

I like the patch!

I would, however, want to suggest to split this:

1) Separate {vmx|svm}_x86_ops change from {vmx|svm}_nested_ops
2) Separate VMX/nVMX from SVM/nSVM
3) Separate other changes (like svm_tlb_flush() -> svm_flush_tlb()
rename, set_irq() -> inject_irq() rename, ...) into induvidual patches.

Or you'll have to provide a script to review it as a whole :-)

-- 
Vitaly




[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux