On 29/05/20 20:27, Krish Sadhukhan wrote: >> >> +static void nested_prepare_vmcb_save(struct vcpu_svm *svm, struct >> vmcb *nested_vmcb) > > > Not a big deal, but I feel that it helps a lot in readability if we keep > the names symmetric. This one could be named prepare_nested_vmcb_save to > match load_nested_vmcb_control that you created in the previous patch. > Or load_nested_vmcb_control could be renamed to nested_load_vmcb_control > to match the name here. This is actually intended: while load_nested_vmcb_control loads the members of nested_vmcb->control into svm->nested, the two functions in this patch prepare the svm->vmcb. A couple patches later, nested_prepare_vmcb_control will not use nested_vmcb anymore. I could use nested_load_nested_vmcb_control, but that is just too ugly! Instead, the best thing to do would be to use the vmcb01/vmcb02/vmcb12 names as in nVMX, in which case the functions would become nested_load_vmcb12_control and nested_prepare_vmcb02_{save,control}. However this is a bit hard to do right now because the svm->vmcb acts as both vmcb01 and vmcb02 depending on what is running. Thanks, Paolo