On 19/02/20 03:45, linmiaohe wrote: > From: Miaohe Lin <linmiaohe@xxxxxxxxxx> > > The second "/* fall through */" in rmode_exception() makes code harder to > read. Replace it with "return" to indicate they are different cases, only > the #DB and #BP check vcpu->guest_debug, while others don't care. And this > also improves the readability. > > Suggested-by: Vitaly Kuznetsov <vkuznets@xxxxxxxxxx> > Reviewed-by: Vitaly Kuznetsov <vkuznets@xxxxxxxxxx> > Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx> > --- > arch/x86/kvm/vmx/vmx.c | 6 ++---- > 1 file changed, 2 insertions(+), 4 deletions(-) > > diff --git a/arch/x86/kvm/vmx/vmx.c b/arch/x86/kvm/vmx/vmx.c > index a13368b2719c..5b8f024f06c2 100644 > --- a/arch/x86/kvm/vmx/vmx.c > +++ b/arch/x86/kvm/vmx/vmx.c > @@ -4492,10 +4492,8 @@ static bool rmode_exception(struct kvm_vcpu *vcpu, int vec) > return false; > /* fall through */ > case DB_VECTOR: > - if (vcpu->guest_debug & > - (KVM_GUESTDBG_SINGLESTEP | KVM_GUESTDBG_USE_HW_BP)) > - return false; > - /* fall through */ > + return !(vcpu->guest_debug & > + (KVM_GUESTDBG_SINGLESTEP | KVM_GUESTDBG_USE_HW_BP)); > case DE_VECTOR: > case OF_VECTOR: > case BR_VECTOR: > Queued, thanks. Paolo