On Fri, May 01, 2020 at 03:30:02PM -0700, Dey, Megha wrote: > Hi Jason, > > On 4/23/2020 1:11 PM, Jason Gunthorpe wrote: > > On Tue, Apr 21, 2020 at 04:34:11PM -0700, Dave Jiang wrote: > > > diff --git a/drivers/base/ims-msi.c b/drivers/base/ims-msi.c > > > new file mode 100644 > > > index 000000000000..738f6d153155 > > > +++ b/drivers/base/ims-msi.c > > > @@ -0,0 +1,100 @@ > > > +// SPDX-License-Identifier: GPL-2.0-only > > > +/* > > > + * Support for Device Specific IMS interrupts. > > > + * > > > + * Copyright © 2019 Intel Corporation. > > > + * > > > + * Author: Megha Dey <megha.dey@xxxxxxxxx> > > > + */ > > > + > > > +#include <linux/dmar.h> > > > +#include <linux/irq.h> > > > +#include <linux/mdev.h> > > > +#include <linux/pci.h> > > > + > > > +/* > > > + * Determine if a dev is mdev or not. Return NULL if not mdev device. > > > + * Return mdev's parent dev if success. > > > + */ > > > +static inline struct device *mdev_to_parent(struct device *dev) > > > +{ > > > + struct device *ret = NULL; > > > + struct device *(*fn)(struct device *dev); > > > + struct bus_type *bus = symbol_get(mdev_bus_type); > > > + > > > + if (bus && dev->bus == bus) { > > > + fn = symbol_get(mdev_dev_to_parent_dev); > > > + ret = fn(dev); > > > + symbol_put(mdev_dev_to_parent_dev); > > > + symbol_put(mdev_bus_type); > > > > No, things like this are not OK in the drivers/base > > > > Whatever this is doing needs to be properly architected in some > > generic way. > > Basically what I am trying to do here is to determine if the device is an > mdev device or not. Why? mdev devices are virtual they don't have HW elements. The caller should use the concrete pci_device to allocate platform_msi? What is preventing this? > > > +struct irq_domain *arch_create_ims_irq_domain(struct irq_domain *parent, > > > + const char *name) > > > +{ > > > + struct fwnode_handle *fn; > > > + struct irq_domain *domain; > > > + > > > + fn = irq_domain_alloc_named_fwnode(name); > > > + if (!fn) > > > + return NULL; > > > + > > > + domain = msi_create_irq_domain(fn, &ims_ir_domain_info, parent); > > > + if (!domain) > > > + return NULL; > > > + > > > + irq_domain_update_bus_token(domain, DOMAIN_BUS_PLATFORM_MSI); > > > + irq_domain_free_fwnode(fn); > > > + > > > + return domain; > > > +} > > > > I'm still not really clear why all this is called IMS.. This looks > > like the normal boilerplate to setup an IRQ domain? What is actually > > 'ims' in here? > > It is just a way to create a new domain specifically for IMS interrupts. > Although, since there is a platform_msi_create_irq_domain already, which > does something similar, I will use the same for IMS as well. But this is all code already intended to be used by the platform, why is it in drivers/base? > Also, since there is quite a stir over the name 'IMS' do you have any > suggestion for a more generic name for this? It seems we have a name, this is called platform_msi in Linux? Jason