On 4/24/20 12:45 PM, Pierre Morel wrote: > First step for testing the channel subsystem is to enumerate the css and > retrieve the css devices. > > This tests the success of STSCH I/O instruction, we do not test the > reaction of the VM for an instruction with wrong parameters. > > Signed-off-by: Pierre Morel <pmorel@xxxxxxxxxxxxx> > --- > lib/s390x/css.h | 1 + > s390x/Makefile | 2 + > s390x/css.c | 92 +++++++++++++++++++++++++++++++++++++++++++++ > s390x/unittests.cfg | 4 ++ > 4 files changed, 99 insertions(+) > create mode 100644 s390x/css.c > > diff --git a/lib/s390x/css.h b/lib/s390x/css.h > index bab0dd5..9417541 100644 > --- a/lib/s390x/css.h > +++ b/lib/s390x/css.h > @@ -82,6 +82,7 @@ struct pmcw { > uint8_t chpid[8]; > uint32_t flags2; > }; > +#define PMCW_CHANNEL_TYPE(pmcw) (pmcw->flags2 >> 21) Why isn't this in the library patch? > > struct schib { > struct pmcw pmcw; > diff --git a/s390x/Makefile b/s390x/Makefile > index ddb4b48..baebf18 100644 > --- a/s390x/Makefile > +++ b/s390x/Makefile > @@ -17,6 +17,7 @@ tests += $(TEST_DIR)/stsi.elf > tests += $(TEST_DIR)/skrf.elf > tests += $(TEST_DIR)/smp.elf > tests += $(TEST_DIR)/sclp.elf > +tests += $(TEST_DIR)/css.elf > tests_binary = $(patsubst %.elf,%.bin,$(tests)) > > all: directories test_cases test_cases_binary > @@ -51,6 +52,7 @@ cflatobjs += lib/s390x/sclp-console.o > cflatobjs += lib/s390x/interrupt.o > cflatobjs += lib/s390x/mmu.o > cflatobjs += lib/s390x/smp.o > +cflatobjs += lib/s390x/css_dump.o Why isn't this in the library patch? > > OBJDIRS += lib/s390x > > diff --git a/s390x/css.c b/s390x/css.c > new file mode 100644 > index 0000000..cc97e79 > --- /dev/null > +++ b/s390x/css.c > @@ -0,0 +1,92 @@ > +/* > + * Channel Subsystem tests > + * > + * Copyright (c) 2020 IBM Corp > + * > + * Authors: > + * Pierre Morel <pmorel@xxxxxxxxxxxxx> > + * > + * This code is free software; you can redistribute it and/or modify it > + * under the terms of the GNU General Public License version 2. > + */ > + > +#include <libcflat.h> > +#include <alloc_phys.h> > +#include <asm/page.h> > +#include <string.h> > +#include <interrupt.h> > +#include <asm/arch_def.h> > + > +#include <css.h> > + > +#define SID_ONE 0x00010000 Why isn't this in the library patch? > + > +static struct schib schib; > +static int test_device_sid; > + > +static void test_enumerate(void) > +{ > + struct pmcw *pmcw = &schib.pmcw; > + int cc; > + int scn; > + int scn_found = 0; > + int dev_found = 0; > + > + for (scn = 0; scn < 0xffff; scn++) { > + cc = stsch(scn|SID_ONE, &schib); > + switch (cc) { > + case 0: /* 0 means SCHIB stored */ > + break; > + case 3: /* 3 means no more channels */ > + goto out; > + default: /* 1 or 2 should never happened for STSCH */ > + report(0, "Unexpected cc=%d on subchannel number 0x%x", > + cc, scn); > + return; > + } > + /* We currently only support type 0, a.k.a. I/O channels */ > + if (PMCW_CHANNEL_TYPE(pmcw) != 0) > + continue; > + /* We ignore I/O channels without valid devices */ > + scn_found++; > + if (!(pmcw->flags & PMCW_DNV)) > + continue; > + /* We keep track of the first device as our test device */ > + if (!test_device_sid) > + test_device_sid = scn|SID_ONE; Give the pipe some space :) > + dev_found++; Newlines would make this more readable. > + } > +out: We can report dev_found instead of 0/1 and a if/else report(dev_found, "Tested subchannels: %d, I/O subchannels: %d, I/O devices: %d", scn, scn_found, dev_found); > + if (!dev_found) { > + report(0, > + "Tested subchannels: %d, I/O subchannels: %d, I/O devices: %d", > + scn, scn_found, dev_found); > + return; > + } > + report(1, > + "Tested subchannels: %d, I/O subchannels: %d, I/O devices: %d", > + scn, scn_found, dev_found); > +} > + > +static struct { > + const char *name; > + void (*func)(void); > +} tests[] = { > + { "enumerate (stsch)", test_enumerate }, > + { NULL, NULL } > +}; > + > +int main(int argc, char *argv[]) > +{ > + int i; > + > + report_prefix_push("Channel Subsystem"); > + for (i = 0; tests[i].name; i++) { > + report_prefix_push(tests[i].name); > + tests[i].func(); > + report_prefix_pop(); > + } > + report_prefix_pop(); > + > + return report_summary(); > +} > diff --git a/s390x/unittests.cfg b/s390x/unittests.cfg > index 07013b2..a436ec0 100644 > --- a/s390x/unittests.cfg > +++ b/s390x/unittests.cfg > @@ -83,3 +83,7 @@ extra_params = -m 1G > [sclp-3g] > file = sclp.elf > extra_params = -m 3G > + > +[css] > +file = css.elf > +extra_params =-device ccw-pong >
Attachment:
signature.asc
Description: OpenPGP digital signature