On Thu, Apr 02, 2020 at 08:05:29AM +0000, Liu, Yi L wrote: > > > > > static long vfio_iommu_type1_ioctl(void *iommu_data, > > > > > default: > > > > > return -EINVAL; > > > > > } > > > > > + > > > > > + } else if (cmd == VFIO_IOMMU_BIND) { > > > > > > > > BIND what? VFIO_IOMMU_BIND_PASID sounds clearer to me. > > > > > > Emm, it's up to the flags to indicate bind what. It was proposed to > > > cover the three cases below: > > > a) BIND/UNBIND_GPASID > > > b) BIND/UNBIND_GPASID_TABLE > > > c) BIND/UNBIND_PROCESS > > > <only a) is covered in this patch> > > > So it's called VFIO_IOMMU_BIND. > > > > but aren't they all about PASID related binding? > > yeah, I can rename it. :-) I don't know if anyone intends to implement it, but SMMUv2 supports nesting translation without any PASID support. For that case the name VFIO_IOMMU_BIND_GUEST_PGTBL without "PASID" anywhere makes more sense. Ideally we'd also use a neutral name for the IOMMU API instead of bind_gpasid(), but that's easier to change later. Thanks, Jean