Re: [PATCH v3 1/2] KVM: VMX: rename 'kvm_area' to 'vmxon_region'

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On 3/6/20 5:02 AM, Vitaly Kuznetsov wrote:
The name 'kvm_area' is misleading (as we have way too many areas which are
KVM related), what alloc_kvm_area()/free_kvm_area() functions really do is
allocate/free VMXON region for all CPUs. Rename accordingly.

No functional change intended.

Reviewed-by: Sean Christopherson <sean.j.christopherson@xxxxxxxxx>
Signed-off-by: Vitaly Kuznetsov <vkuznets@xxxxxxxxxx>
---
  arch/x86/kvm/vmx/vmx.c | 10 +++++-----
  1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/arch/x86/kvm/vmx/vmx.c b/arch/x86/kvm/vmx/vmx.c
index 40b1e6138cd5..dab19e4e5f2b 100644
--- a/arch/x86/kvm/vmx/vmx.c
+++ b/arch/x86/kvm/vmx/vmx.c
@@ -2635,7 +2635,7 @@ int alloc_loaded_vmcs(struct loaded_vmcs *loaded_vmcs)
  	return -ENOMEM;
  }
-static void free_kvm_area(void)
+static void free_vmxon_regions(void)
  {
  	int cpu;
@@ -2645,7 +2645,7 @@ static void free_kvm_area(void)
  	}
  }
-static __init int alloc_kvm_area(void)
+static __init int alloc_vmxon_regions(void)
  {
  	int cpu;
@@ -2654,7 +2654,7 @@ static __init int alloc_kvm_area(void) vmcs = alloc_vmcs_cpu(false, cpu, GFP_KERNEL);
  		if (!vmcs) {
-			free_kvm_area();
+			free_vmxon_regions();
  			return -ENOMEM;
  		}
@@ -7815,7 +7815,7 @@ static __init int hardware_setup(void)
  			return r;
  	}
- r = alloc_kvm_area();
+	r = alloc_vmxon_regions();
  	if (r)
  		nested_vmx_hardware_unsetup();
  	return r;
@@ -7826,7 +7826,7 @@ static __exit void hardware_unsetup(void)
  	if (nested)
  		nested_vmx_hardware_unsetup();
- free_kvm_area();
+	free_vmxon_regions();
  }
static bool vmx_check_apicv_inhibit_reasons(ulong bit)
Reviewed-by: Krish Sadhukhan <krish.sadhukhan@xxxxxxxxxx>



[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux