Re: [PATCH] KVM: s390: introduce module parameter kvm.use_gisa

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On 27.02.20 13:43, Michael Mueller wrote:
> 
> 
> On 27.02.20 13:27, Christian Borntraeger wrote:
>>
>>
>> On 27.02.20 10:10, Michael Mueller wrote:
>>> The boolean module parameter "kvm.use_gisa" controls if newly
>>> created guests will use the GISA facility if provided by the
>>> host system. The default is yes.
>>>
>>>    # cat /sys/module/kvm/parameters/use_gisa
>>>    Y
>>>
>>> The parameter can be changed on the fly.
>>>
>>>    # echo N > /sys/module/kvm/parameters/use_gisa
>>>
>>> Already running guests are not affected by this change.
>>>
>>> The kvm s390 debug feature shows if a guest is running with GISA.
>>>
>>>    # grep gisa /sys/kernel/debug/s390dbf/kvm-$pid/sprintf
>>>    00 01582725059:843303 3 - 08 00000000e119bc01  gisa 0x00000000c9ac2642 initialized
>>>    00 01582725059:903840 3 - 11 000000004391ee22  00[0000000000000000-0000000000000000]: AIV gisa format-1 enabled for cpu 000
>>>    ...
>>>    00 01582725059:916847 3 - 08 0000000094fff572  gisa 0x00000000c9ac2642 cleared
>>>
>>> In general, that value should not be changed as the GISA facility
>>> enhances interruption delivery performance.
>>>
>>> A reason to switch the GISA facility off might be a performance
>>> comparison run or debugging.
>>>
>>> Signed-off-by: Michael Mueller <mimu@xxxxxxxxxxxxx>
>>
>> Looks good to me. Regarding the other comments, I think allowing for dynamic changes
>> and keeping use_gisa vs disable_gisa makes sense. So I would think that the patch
>> as is makes sense.
>>
>> The only question is: shall we set use_gisa to 0 when the machine does not support
>> it (e.g. VSIE?) and then also forbid setting it to 1? Could be overkill.
> 
> Then I would rename the parameter to "try_to_use_gisa" instead. (a joke ;) )
> 
> In that case we exit gisa_init() because of the missing AIV facility.
> 
> void kvm_s390_gisa_init(struct kvm *kvm)
> {
>         struct kvm_s390_gisa_interrupt *gi = &kvm->arch.gisa_int;
> 
> -->    if (!css_general_characteristics.aiv)
>                 return;
>         gi->origin = &kvm->arch.sie_page2->gisa;
>         gi->alert.mask = 0;
>     ...
> }
> 

I know. My point was more: "can we expose this". But this is probably overkill.




[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux