On Fri, Dec 20, 2019 at 10:33:25AM +0100, Cornelia Huck wrote: > On Wed, 18 Dec 2019 13:55:15 -0800 > Sean Christopherson <sean.j.christopherson@xxxxxxxxx> wrote: > > +int kvm_arch_vcpu_create(struct kvm_vcpu *vcpu) > > { > > - struct kvm_vcpu *vcpu; > > struct sie_page *sie_page; > > int rc; > > > > - rc = -ENOMEM; > > - > > - vcpu = kmem_cache_zalloc(kvm_vcpu_cache, GFP_KERNEL); > > - if (!vcpu) > > - goto out; > > - > > - rc = kvm_vcpu_init(vcpu, kvm, id); > > - if (rc) > > - goto out_free_cpu; > > - > > - rc = -ENOMEM; > > - > > BUILD_BUG_ON(sizeof(struct sie_page) != 4096); > > sie_page = (struct sie_page *) get_zeroed_page(GFP_KERNEL); > > if (!sie_page) > > - goto out_uninit_vcpu; > > + return -ENOMEM; > > > > vcpu->arch.sie_block = &sie_page->sie_block; > > vcpu->arch.sie_block->itdba = (unsigned long) &sie_page->itdb; > > @@ -3087,15 +3070,11 @@ struct kvm_vcpu *kvm_arch_vcpu_create(struct kvm *kvm, > > vcpu->arch.sie_block); > > trace_kvm_s390_create_vcpu(id, vcpu, vcpu->arch.sie_block); > > > > - return vcpu; > > + return 0; > > + > > out_free_sie_block: > > free_page((unsigned long)(vcpu->arch.sie_block)); > > -out_uninit_vcpu: > > - kvm_vcpu_uninit(vcpu); > > -out_free_cpu: > > - kmem_cache_free(kvm_vcpu_cache, vcpu); > > -out: > > - return ERR_PTR(rc); > > + return rc; > > This is getting a bit hard to follow across the patches, but I think rc > is now only set for ucontrol guests. So this looks correct right now, > but feels a bit brittle... should we maybe init rc to 0 and always > return rc instead? Yes, but only for a few patches until kvm_s390_vcpu_setup() is introduced, at which point @rc is unconditionally set at the end. rc = kvm_s390_vcpu_setup(vcpu); if (rc) goto out_free_ucontrol_gmap; return 0; My personal preference is to use "return 0;" when the return is known to be zero as it makes the success path obvious at a glance. I also didn't want to intialize @rc at he beginning because then the sie_page allocation would look a bit funky: int rc = 0; BUILD_BUG_ON(sizeof(struct sie_page) != 4096); sie_page = (struct sie_page *) get_zeroed_page(GFP_KERNEL); if (!sie_page) return -ENOMEM; An alternative would be to init @rc to -ENOMEM: int rc = -ENOMEM; BUILD_BUG_ON(sizeof(struct sie_page) != 4096); sie_page = (struct sie_page *) get_zeroed_page(GFP_KERNEL); if (!sie_page) return rc; This would be my preference if you'd prefer to init @rc right away, especially if __kvm_ucontrol_vcpu_init() is open coded here (discussion in patch 35, "KVM: s390: Manually invoke vcpu setup during kvm_arch_vcpu_create()", e.g.: int rc = -ENOMEM; BUILD_BUG_ON(sizeof(struct sie_page) != 4096); sie_page = (struct sie_page *) get_zeroed_page(GFP_KERNEL); if (!sie_page) return rc; ... if (kvm_is_ucontrol(vcpu->kvm)) { vcpu->arch.gmap = gmap_create(current->mm, -1UL); if (!vcpu->arch.gmap) goto out_free_sie_block; vcpu->arch.gmap->private = vcpu->kvm; } VM_EVENT(kvm, 3, "create cpu %d at 0x%pK, sie block at 0x%pK", id, vcpu, vcpu->arch.sie_block); trace_kvm_s390_create_vcpu(id, vcpu, vcpu->arch.sie_block); rc = kvm_s390_vcpu_setup(vcpu); if (rc) goto out_free_ucontrol_gmap; return 0; out_free_ucontrol_gmap: if (kvm_is_ucontrol(vcpu->kvm)) gmap_remove(vcpu->arch.gmap); out_free_sie_block: free_page((unsigned long)(vcpu->arch.sie_block)); return rc;