On 11/12/19 22:32, Barret Rhoden wrote: > + /* > + * Our caller grabbed the KVM mmu_lock with a successful > + * mmu_notifier_retry, so we're safe to walk the page table. > + */ > + switch (dev_pagemap_mapping_shift(hva, current->mm)) { > + case PMD_SHIFT: > + case PUD_SIZE: > + return true; > + } > + return false; Should this simply be "> PAGE_SHIFT"? Paolo