Re: [PATCH] tools/kvm_stat: Fix kvm_exit filter name

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 12/10/19 7:45 PM, Vitaly Kuznetsov wrote:
Gavin Shan <gshan@xxxxxxxxxx> writes:

The filter name is fixed to "exit_reason" for some kvm_exit events, no
matter what architect we have. Actually, the filter name ("exit_reason")
is only applicable to x86, meaning it's broken on other architects
including aarch64.

This fixes the issue by providing various kvm_exit filter names, depending
on architect we're on. Afterwards, the variable filter name is picked and
applied through ioctl(fd, SET_FILTER).

Would it actually make sense to standardize (to certain extent) kvm_exit
tracepoints instead?


Yes, It makes sense, but it's something for future if you agree. Besides,
It seems that other kvm tracepoints need standardization either.


Reported-by: Andrew Jones <drjones@xxxxxxxxxx>
Signed-off-by: Gavin Shan <gshan@xxxxxxxxxx>
---
  tools/kvm/kvm_stat/kvm_stat | 8 ++++++--
  1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/tools/kvm/kvm_stat/kvm_stat b/tools/kvm/kvm_stat/kvm_stat
index ad1b9e646c49..f9273614b7e3 100755
--- a/tools/kvm/kvm_stat/kvm_stat
+++ b/tools/kvm/kvm_stat/kvm_stat
@@ -270,6 +270,7 @@ class ArchX86(Arch):
      def __init__(self, exit_reasons):
          self.sc_perf_evt_open = 298
          self.ioctl_numbers = IOCTL_NUMBERS
+        self.exit_field = 'exit_reason'

Also, 'exit_field' name is confusing (probably because I'm thinking of
VMCS fields)


Ok. How about to have 'exit_reason_field' or 'exit_filter_name'?

          self.exit_reasons = exit_reasons
def debugfs_is_child(self, field):
@@ -289,6 +290,7 @@ class ArchPPC(Arch):
          # numbers depend on the wordsize.
          char_ptr_size = ctypes.sizeof(ctypes.c_char_p)
          self.ioctl_numbers['SET_FILTER'] = 0x80002406 | char_ptr_size << 16
+        self.exit_field = 'exit_nr'
          self.exit_reasons = {}
def debugfs_is_child(self, field):
@@ -300,6 +302,7 @@ class ArchA64(Arch):
      def __init__(self):
          self.sc_perf_evt_open = 241
          self.ioctl_numbers = IOCTL_NUMBERS
+        self.exit_field = 'ret'

And this is the most confusing part. Why do we have 'ret' as an exit
reason in the first place?


ah, it turns to be 'esr_ec', which is the class code from ESR_EL2. Will fix in v2.
The field name isn't meaningful and it's to be sorted out in future standardization
by the way :)


          self.exit_reasons = AARCH64_EXIT_REASONS
def debugfs_is_child(self, field):
@@ -311,6 +314,7 @@ class ArchS390(Arch):
      def __init__(self):
          self.sc_perf_evt_open = 331
          self.ioctl_numbers = IOCTL_NUMBERS
+        self.exit_field = None
          self.exit_reasons = None
def debugfs_is_child(self, field):
@@ -541,8 +545,8 @@ class TracepointProvider(Provider):
          """
          filters = {}
          filters['kvm_userspace_exit'] = ('reason', USERSPACE_EXIT_REASONS)
-        if ARCH.exit_reasons:
-            filters['kvm_exit'] = ('exit_reason', ARCH.exit_reasons)
+        if ARCH.exit_field and ARCH.exit_reasons:
+            filters['kvm_exit'] = (ARCH.exit_field, ARCH.exit_reasons)
          return filters
def _get_available_fields(self):


Regards,
Gavin




[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux