> On 5 Nov 2019, at 21:19, Aaron Lewis <aaronlewis@xxxxxxxxxx> wrote: > > Rename NR_AUTOLOAD_MSRS to NR_MSR_ENTRIES. This needs to be done > due to the addition of the MSR-autostore area that will be added later > in this series. After that the name AUTOLOAD will no longer make sense. > > Reviewed-by: Jim Mattson <jmattson@xxxxxxxxxx> > Signed-off-by: Aaron Lewis <aaronlewis@xxxxxxxxxx> NR_MSR_ENTRIES is a bit too generic in my opinion. I would prefer to rename to NR_AUTO_LOADSTORE_MSRS. The change itself is fine. -Liran > --- > arch/x86/kvm/vmx/vmx.c | 4 ++-- > arch/x86/kvm/vmx/vmx.h | 4 ++-- > 2 files changed, 4 insertions(+), 4 deletions(-) > > diff --git a/arch/x86/kvm/vmx/vmx.c b/arch/x86/kvm/vmx/vmx.c > index e7970a2e8eae..c0160ca9ddba 100644 > --- a/arch/x86/kvm/vmx/vmx.c > +++ b/arch/x86/kvm/vmx/vmx.c > @@ -940,8 +940,8 @@ static void add_atomic_switch_msr(struct vcpu_vmx *vmx, unsigned msr, > if (!entry_only) > j = find_msr(&m->host, msr); > > - if ((i < 0 && m->guest.nr == NR_AUTOLOAD_MSRS) || > - (j < 0 && m->host.nr == NR_AUTOLOAD_MSRS)) { > + if ((i < 0 && m->guest.nr == NR_MSR_ENTRIES) || > + (j < 0 && m->host.nr == NR_MSR_ENTRIES)) { > printk_once(KERN_WARNING "Not enough msr switch entries. " > "Can't add msr %x\n", msr); > return; > diff --git a/arch/x86/kvm/vmx/vmx.h b/arch/x86/kvm/vmx/vmx.h > index bee16687dc0b..0c6835bd6945 100644 > --- a/arch/x86/kvm/vmx/vmx.h > +++ b/arch/x86/kvm/vmx/vmx.h > @@ -22,11 +22,11 @@ extern u32 get_umwait_control_msr(void); > > #define X2APIC_MSR(r) (APIC_BASE_MSR + ((r) >> 4)) > > -#define NR_AUTOLOAD_MSRS 8 > +#define NR_MSR_ENTRIES 8 > > struct vmx_msrs { > unsigned int nr; > - struct vmx_msr_entry val[NR_AUTOLOAD_MSRS]; > + struct vmx_msr_entry val[NR_MSR_ENTRIES]; > }; > > struct shared_msr_entry { > -- > 2.24.0.rc1.363.gb1bccd3e3d-goog >