Re: [PATCH v2 2/2] KVM: CPUID: Put maxphyaddr updating together with virtual address width checking

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Sep 10, 2019 at 3:52 PM Xiaoyao Li <xiaoyao.li@xxxxxxxxx> wrote:
>
> On Tue, 2019-09-10 at 10:13 -0700, Jim Mattson wrote:
> > On Tue, Sep 10, 2019 at 3:42 AM Xiaoyao Li <xiaoyao.li@xxxxxxxxx> wrote:
> > >
> > > Since both of maxphyaddr updating and virtual address width checking
> > > need to query the cpuid leaf 0x80000008. We can put them together.
> > >
> > > Signed-off-by: Xiaoyao Li <xiaoyao.li@xxxxxxxxx>
> > > ---
> > >  arch/x86/kvm/cpuid.c | 6 ++++--
> > >  1 file changed, 4 insertions(+), 2 deletions(-)
> > >
> > > diff --git a/arch/x86/kvm/cpuid.c b/arch/x86/kvm/cpuid.c
> > > index 67fa44ab87af..fd0a66079001 100644
> > > --- a/arch/x86/kvm/cpuid.c
> > > +++ b/arch/x86/kvm/cpuid.c
> > > @@ -118,6 +118,7 @@ int kvm_update_cpuid(struct kvm_vcpu *vcpu)
> > >                 best->ebx = xstate_required_size(vcpu->arch.xcr0, true);
> > >
> > >         /*
> > > +        * Update physical address width and check virtual address width.
> > >          * The existing code assumes virtual address is 48-bit or 57-bit in
> > > the
> > >          * canonical address checks; exit if it is ever changed.
> > >          */
> > > @@ -127,7 +128,10 @@ int kvm_update_cpuid(struct kvm_vcpu *vcpu)
> > >
> > >                 if (vaddr_bits != 48 && vaddr_bits != 57 && vaddr_bits != 0)
> > >                         return -EINVAL;
> > > +
> > > +               vcpu->arch.maxphyaddr = best->eax & 0xff;
> > >         }
> > > +       vcpu->arch.maxphyaddr = 36;
> >
> > Perhaps I'm missing something, but it looks to me like you always set
> > vcpu->arch.maxphyaddr to 36, regardless of what may be enumerated by
> > leaf 0x80000008.
>
> Oh, I made a stupid mistake. It should be included in the else case.
>
> >
> > Is there really much of an advantage to open-coding
> > cpuid_query_maxphyaddr() here?
>
> Indeed not so much.
> It can avoid two more kvm_find_cpuid_entry() calling that we don't handle leaf
> 0x80000008 twice in two place.

I'm inclined to leave things as they are. As your previous attempt
demonstrates, having the same logic replicated in multiple places is
prone to error. I can't imagine that this would be a
performance-sensitive path.

> > >         best = kvm_find_cpuid_entry(vcpu, KVM_CPUID_FEATURES, 0);
> > >         if (kvm_hlt_in_guest(vcpu->kvm) && best &&
> > > @@ -144,8 +148,6 @@ int kvm_update_cpuid(struct kvm_vcpu *vcpu)
> > >                 }
> > >         }
> > >
> > > -       /* Update physical-address width */
> > > -       vcpu->arch.maxphyaddr = cpuid_query_maxphyaddr(vcpu);
> > >         kvm_mmu_reset_context(vcpu);
> > >
> > >         kvm_pmu_refresh(vcpu);
> > > --
> > > 2.19.1
> > >
>



[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux