Frederic Weisbecker wrote: > On Tue, Jul 07, 2009 at 03:55:28PM -0400, Masami Hiramatsu wrote: >> Frederic Weisbecker wrote: >>>> diff --git a/kernel/trace/trace.h b/kernel/trace/trace.h >>>> index 206cb7d..65945eb 100644 >>>> --- a/kernel/trace/trace.h >>>> +++ b/kernel/trace/trace.h >>>> @@ -45,6 +45,8 @@ enum trace_type { >>>> TRACE_POWER, >>>> TRACE_BLK, >>>> TRACE_KSYM, >>>> + TRACE_KPROBE, >>>> + TRACE_KRETPROBE, >>>> >>>> __TRACE_LAST_TYPE, >>>> }; >>>> @@ -227,6 +229,22 @@ struct trace_ksym { >>>> char ksym_name[KSYM_NAME_LEN]; >>>> char p_name[TASK_COMM_LEN]; >>>> }; >>>> +#define TRACE_KPROBE_ARGS 6 >>>> + >>>> +struct kprobe_trace_entry { >>>> + struct trace_entry ent; >>>> + unsigned long ip; >>>> + int nargs; >>>> + unsigned long args[TRACE_KPROBE_ARGS]; >>> >>> >>> I see that you actually make use of arg as a dynamic sizeable >>> array. >>> For clarity, args[TRACE_KPROBE_ARGS] could be args[0]. >>> >>> It's just a neat and wouldn't affect the code nor the data >>> but would be clearer for readers of that code. >> Hmm. In that case, I think we'll need a new macro for field >> definition, like TRACE_FIELD_ZERO(type, item). > > > > You mean that for trace_define_field() to describe fields of events? > Actually the fields should be defined dynamically depending on how > is built the kprobe event (which arguments are requested, how many, > etc..). Yeah, if you specified a probe point with its event name, the tracer will make a corresponding event dynamically. There are also anonymous probes which don't have corresponding events. For those anonymous probes, I need to define two generic event types(kprobe and kretprobe). Thank you, -- Masami Hiramatsu Software Engineer Hitachi Computer Products (America), Inc. Software Solutions Division e-mail: mhiramat@xxxxxxxxxx -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html