Re: [PATCH 2/3] kvm: x86: use same convention to name apic_clear_vector()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 01/04/19 04:17, Wei Yang wrote:
> apic_clear_vector() is the counterpart of kvm_lapic_clear_vector(),
> while they have different naming convention.
> 
> Rename it and move together to arch/x86/kvm/lapic.h. Also fix one typo
> in comment by hand.

You mean "of kvm_lapic_set_vector()".  Queued all three with only this
change to the commit log, sorry for the delay.

Paolo

> Signed-off-by: Wei Yang <richardw.yang@xxxxxxxxxxxxxxx>
> ---
>  arch/x86/kvm/lapic.c | 17 +++++++----------
>  arch/x86/kvm/lapic.h |  5 +++++
>  2 files changed, 12 insertions(+), 10 deletions(-)
> 
> diff --git a/arch/x86/kvm/lapic.c b/arch/x86/kvm/lapic.c
> index c4533d05c214..d8b3cbba8e29 100644
> --- a/arch/x86/kvm/lapic.c
> +++ b/arch/x86/kvm/lapic.c
> @@ -88,11 +88,6 @@ bool kvm_apic_pending_eoi(struct kvm_vcpu *vcpu, int vector)
>  		apic_test_vector(vector, apic->regs + APIC_IRR);
>  }
>  
> -static inline void apic_clear_vector(int vec, void *bitmap)
> -{
> -	clear_bit(VEC_POS(vec), (bitmap) + REG_POS(vec));
> -}
> -
>  static inline int __apic_test_and_set_vector(int vec, void *bitmap)
>  {
>  	return __test_and_set_bit(VEC_POS(vec), (bitmap) + REG_POS(vec));
> @@ -445,12 +440,12 @@ static inline void apic_clear_irr(int vec, struct kvm_lapic *apic)
>  
>  	if (unlikely(vcpu->arch.apicv_active)) {
>  		/* need to update RVI */
> -		apic_clear_vector(vec, apic->regs + APIC_IRR);
> +		kvm_lapic_clear_vector(vec, apic->regs + APIC_IRR);
>  		kvm_x86_ops->hwapic_irr_update(vcpu,
>  				apic_find_highest_irr(apic));
>  	} else {
>  		apic->irr_pending = false;
> -		apic_clear_vector(vec, apic->regs + APIC_IRR);
> +		kvm_lapic_clear_vector(vec, apic->regs + APIC_IRR);
>  		if (apic_search_irr(apic) != -1)
>  			apic->irr_pending = true;
>  	}
> @@ -1053,9 +1048,11 @@ static int __apic_accept_irq(struct kvm_lapic *apic, int delivery_mode,
>  
>  		if (apic_test_vector(vector, apic->regs + APIC_TMR) != !!trig_mode) {
>  			if (trig_mode)
> -				kvm_lapic_set_vector(vector, apic->regs + APIC_TMR);
> +				kvm_lapic_set_vector(vector,
> +						     apic->regs + APIC_TMR);
>  			else
> -				apic_clear_vector(vector, apic->regs + APIC_TMR);
> +				kvm_lapic_clear_vector(vector,
> +						       apic->regs + APIC_TMR);
>  		}
>  
>  		if (vcpu->arch.apicv_active)
> @@ -2278,7 +2275,7 @@ int kvm_create_lapic(struct kvm_vcpu *vcpu)
>  
>  	/*
>  	 * APIC is created enabled. This will prevent kvm_lapic_set_base from
> -	 * thinking that APIC satet has changed.
> +	 * thinking that APIC state has changed.
>  	 */
>  	vcpu->arch.apic_base = MSR_IA32_APICBASE_ENABLE;
>  	static_key_slow_inc(&apic_sw_disabled.key); /* sw disabled at reset */
> diff --git a/arch/x86/kvm/lapic.h b/arch/x86/kvm/lapic.h
> index ff6ef9c3d760..339ee029be6e 100644
> --- a/arch/x86/kvm/lapic.h
> +++ b/arch/x86/kvm/lapic.h
> @@ -127,6 +127,11 @@ void kvm_lapic_exit(void);
>  #define VEC_POS(v) ((v) & (32 - 1))
>  #define REG_POS(v) (((v) >> 5) << 4)
>  
> +static inline void kvm_lapic_clear_vector(int vec, void *bitmap)
> +{
> +	clear_bit(VEC_POS(vec), (bitmap) + REG_POS(vec));
> +}
> +
>  static inline void kvm_lapic_set_vector(int vec, void *bitmap)
>  {
>  	set_bit(VEC_POS(vec), (bitmap) + REG_POS(vec));
> 




[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux