On Fri, 26 Apr 2019 15:01:27 +0200 Pierre Morel <pmorel@xxxxxxxxxxxxx> wrote: > diff --git a/drivers/s390/crypto/vfio_ap_private.h b/drivers/s390/crypto/vfio_ap_private.h > index 18dcc4d..7cc02ff 100644 > --- a/drivers/s390/crypto/vfio_ap_private.h > +++ b/drivers/s390/crypto/vfio_ap_private.h > @@ -4,6 +4,7 @@ > * > * Author(s): Tony Krowiak <akrowiak@xxxxxxxxxxxxx> > * Halil Pasic <pasic@xxxxxxxxxxxxx> > + * Pierre Morel <pmorel@xxxxxxxxxxxxx> > * > * Copyright IBM Corp. 2018 > */ > @@ -90,4 +91,14 @@ struct ap_matrix_mdev { > extern int vfio_ap_mdev_register(void); > extern void vfio_ap_mdev_unregister(void); > > +struct vfio_ap_queue { > + struct ap_matrix_mdev *matrix_mdev; > + unsigned long a_nib; > + unsigned long a_pfn; > + unsigned long p_pfn; > + int apqn; > +#define VFIO_AP_ISC_INVALID 0xff How about -1? > + unsigned char a_isc; > + unsigned char p_isc; > +}; > #endif /* _VFIO_AP_PRIVATE_H_ */ I assume a_ and p_ are for argument and private, or? Anyway it would be nice to have nicer names for these. If the a_ members are really just arguments, we could probably live without the. I'm fine either way. Regards, Halil