On Wed, 19 Dec 2018 20:17:47 +0100 Michael Mueller <mimu@xxxxxxxxxxxxx> wrote: > This will shorten the length of code lines. > All GISA related static inline functions are local to interrupt.c > > Signed-off-by: Michael Mueller <mimu@xxxxxxxxxxxxx> > --- > arch/s390/kvm/interrupt.c | 26 +++++++++++++------------- > 1 file changed, 13 insertions(+), 13 deletions(-) > > diff --git a/arch/s390/kvm/interrupt.c b/arch/s390/kvm/interrupt.c > index 4ab20d2eb180..9b1fa39b6f90 100644 > --- a/arch/s390/kvm/interrupt.c > +++ b/arch/s390/kvm/interrupt.c > @@ -224,22 +224,22 @@ static inline u8 int_word_to_isc(u32 int_word) > */ > #define IPM_BIT_OFFSET (offsetof(struct kvm_s390_gisa, ipm) * BITS_PER_BYTE) > > -static inline void kvm_s390_gisa_set_ipm_gisc(struct kvm_s390_gisa *gisa, u32 gisc) > +static inline void set_ipm_gisc(struct kvm_s390_gisa *gisa, u32 gisc) > { > set_bit_inv(IPM_BIT_OFFSET + gisc, (unsigned long *) gisa); > } > > -static inline u8 kvm_s390_gisa_get_ipm(struct kvm_s390_gisa *gisa) > +static inline u8 get_ipm(struct kvm_s390_gisa *gisa) > { > return READ_ONCE(gisa->ipm); > } > > -static inline void kvm_s390_gisa_clear_ipm_gisc(struct kvm_s390_gisa *gisa, u32 gisc) > +static inline void clear_ipm_gisc(struct kvm_s390_gisa *gisa, u32 gisc) > { > clear_bit_inv(IPM_BIT_OFFSET + gisc, (unsigned long *) gisa); > } > > -static inline int kvm_s390_gisa_tac_ipm_gisc(struct kvm_s390_gisa *gisa, u32 gisc) > +static inline int tac_ipm_gisc(struct kvm_s390_gisa *gisa, u32 gisc) > { > return test_and_clear_bit_inv(IPM_BIT_OFFSET + gisc, (unsigned long *) gisa); > } I don't disagree with making them shorter, but I think the code would be more readable if you only dropped the kvm_s390_ prefix and kept annotating the functions as gisa_.