On 12/12/18 19:30, Krish Sadhukhan wrote: > v4 -> v5: > 1. In patch# 1, the prefix has been changed to 'nested_vmx_'. > 2. The groups of checks in their respective sub-functions have further > been ordered according to the SDM. Note that I haven't collapsed > all the checks in nested_check_vm_execution_controls() in patch# 2, > in a single if-else block because that may not be readable and > elegant. > > > [PATCH v5 1/7] KVM: nVMX: Prepend "nested_vmx_" to > [PATCH v5 2/7] KVM: nVMX: Move the checks for VM-Execution Control > [PATCH v5 3/7] KVM: nVMX: Remove param indirection from > [PATCH v5 4/7] KVM: nVMX: Move the checks for VM-Exit Control Fields to > [PATCH v5 5/7] KVM: nVMX: Move the checks for VM-Entry Control Fields to > [PATCH v5 6/7] KVM: nVMX: Move the checks for Host Control Registers and > [PATCH v5 7/7] KVM: nVMX: Move the checks for Guest Non-Register States > > arch/x86/kvm/vmx.c | 268 +++++++++++++++++++++++++++++++---------------------- > 1 file changed, 158 insertions(+), 110 deletions(-) > > Krish Sadhukhan (6): > KVM: nVMX: Prepend "nested_vmx_" to check_vmentry_{pre,post}reqs() > KVM: nVMX: Move the checks for VM-Execution Control Fields to a separate helper function > KVM: nVMX: Move the checks for VM-Exit Control Fields to a separate helper function > KVM: nVMX: Move the checks for VM-Entry Control Fields to a separate helper function > KVM: nVMX: Move the checks for Host Control Registers and MSRs to a separate helper function > KVM: nVMX: Move the checks for Guest Non-Register States to a separate helper function > > Sean Christopherson (1): > KVM: nVMX: Remove param indirection from nested_vmx_check_msr_switch() > Queued, thanks. Paolo