KVM: nVMX: Re-name check_vmentry_{pre,post}reqs() and re-organize check_vmentry_prereqs (v3)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



v2 -> v3:
	1. Commit messages are more concise and meaningful
	2. Addition of patch# 3 (from sean.j.christopherson@xxxxxxxxx)
	3. Removal of the comment from nested_check_guest_non_reg_state()
	4. Expansion of words in some of the function names


[PATCH 1/7] KVM: nVMX: Prepend "nested_" to
[PATCH 2/7] KVM: nVMX: Move the checks for VM-Execution Control
[PATCH 3/7] KVM: nVMX: Remove param indirection from
[PATCH 4/7] KVM: nVMX: Move the checks for VM-Exit Control Fields to
[PATCH 5/7] KVM: nVMX: Move the checks for VM-Entry Control Fields to
[PATCH 6/7] KVM: nVMX: Move the checks for Host Control Registers and
[PATCH 7/7] KVM: nVMX: Move the checks for Guest Non-Register States

 arch/x86/kvm/vmx.c | 181 ++++++++++++++++++++++++++++++----------------------
 1 file changed, 106 insertions(+), 75 deletions(-)

Krish Sadhukhan (6):
      KVM: nVMX: Prepend "nested_" to check_vmentry_{pre,post}reqs()
      KVM: nVMX: Move the checks for VM-Execution Control Fields to a separate helper function
      KVM: nVMX: Move the checks for VM-Exit Control Fields to a separate helper function
      KVM: nVMX: Move the checks for VM-Entry Control Fields to a separate helper function
      KVM: nVMX: Move the checks for Host Control Registers and MSRs to a separate helper function
      KVM: nVMX: Move the checks for Guest Non-Register States to a separate helper function

Sean Christopherson (1):
      KVM: nVMX: Remove param indirection from nested_vmx_check_msr_switch()



[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux