nVMX x86: Re-name check_vmentry_pre[post]reqs and re-organize check_vmentry_prereqs

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



According to Intel SDM vol 3C, VMCS data is of six different types. But the
single function check_vmentry_prereqs currently holds all the different types
of checks related to those six types of VMCS data. This patch series
re-organizes the checks in that function into six different sub-functions
based on the VMCS data organization. The re-organized code is easier for
readability, enhancement and maintenance.


[PATCH 1/6] nVMX x86: Re-name check_vmentry_pre[post]reqs to
[PATCH 2/6] nVMX x86: Re-organize the code in
[PATCH 3/6] nVMX x86: Re-organize the code in
[PATCH 4/6] nVMX x86: Re-organize the code in
[PATCH 5/6] nVMX x86: Re-organize the code in
[PATCH 6/6] nVMX x86: Re-organize the code in

 arch/x86/kvm/vmx.c | 133 +++++++++++++++++++++++++++++++++--------------------
 1 file changed, 82 insertions(+), 51 deletions(-)

Krish Sadhukhan (6):
      nVMX x86: Re-name check_vmentry_pre[post]reqs to nested_check_vmentry_pre[post]
      nVMX x86: Re-organize the code in nested_check_vmentry_prereqs(), related to Guest State Area
      nVMX x86: Re-organize the code in nested_check_vmentry_prereqs(), that are related to Host State Area
      nVMX x86: Re-organize the code in nested_check_vmentry_prereqs(), that is related to VM-Execution Control Fields
      nVMX x86: Re-organize the code in check_vmentry_prereqs(), that are related to VM-Exit Control Fields
      nVMX x86: Re-organize the code in check_vmentry_prereqs(), that are related to VM-Entry Control Fields



[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux