Re: [Patch v3 0/3] Introduce a new pte_list_remove()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 04/10/2018 04:04, Wei Yang wrote:
> rmap_remove() would remove the sptep after locating the correct rmap_head.
> While in several cases, the caller has already known the correct rmap_head.
> 
> This patch set tries to remove a spte from rmap_head directly.
> 
> The original discussion is posted at:
> 
>     https://patchwork.kernel.org/patch/10615385/
> 
> This version dose some change based on Paolo's comments:
> 
>   * rename the original pte_list_remove to __pte_list_remove
>   * remove the *if* check on mmu_spte_clear_track_bits in new pte_list_remove
>   * move mmu_spte_clear_track_bits before *if* branch in kvm_set_pte_rmapp
> 
> v3:
>   * fix warning from checkpatch.pl in __pte_list_remove
> 
> Wei Yang (3):
>   KVM: x86: rename pte_list_remove to __pte_list_remove
>   KVM: x86: a new pte_list_remove including mmu_spte_clear_track_bits
>   KVM: x86: extract mmu_spte_clear_track_bits in the loop of
>     kvm_set_pte_rmapp
> 
>  arch/x86/kvm/mmu.c | 30 ++++++++++++++++++------------
>  1 file changed, 18 insertions(+), 12 deletions(-)
> 


Thanks.  I'm not sure that patch 3 improves the readability of the code,
so I'm only applying 1 and 2 for now.

Paolo



[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux