Series applied. Thanks On 01/23/2018 06:05 PM, David Hildenbrand wrote: > We already have __set_cpuflag(), but its limited to interrupt.c. Conny > suggested __clear_cpuflag(). I went one step further and introduce > - kvm_s390_set_cpuflags() > - kvm_s390_clear_cpuflags() > - kvm_s390_test_cpuflags() > > All applicable places are converted to use the new helpers. This beautifies > the code at a couple of places quite a bit. > > David Hildenbrand (4): > KVM: s390: rename __set_cpuflag() to kvm_s390_set_cpuflags() > KVM: s390: reuse kvm_s390_set_cpuflags() > KVM: s390: introduce and use kvm_s390_clear_cpuflags() > KVM: s390: introduce and use kvm_s390_test_cpuflags() > > arch/s390/kvm/interrupt.c | 43 +++++++++++++++++++------------------------ > arch/s390/kvm/kvm-s390.c | 30 ++++++++++++++---------------- > arch/s390/kvm/kvm-s390.h | 17 ++++++++++++++++- > arch/s390/kvm/priv.c | 6 +++--- > arch/s390/kvm/sigp.c | 14 +++++--------- > arch/s390/kvm/vsie.c | 4 ++-- > 6 files changed, 59 insertions(+), 55 deletions(-) >