On Fri, Nov 17, 2017 at 10:19 AM, Nadav Amit <namit@xxxxxxxxxx> wrote: > +static inline void update_cr4(unsigned long cr4) > +{ > +#ifdef CONFIG_LOCKDEP > + WARN_ON(!irqs_disabled()); > +#endif > + this_cpu_write(cpu_tlbstate.cr4, cr4); > + __write_cr4(cr4); > +} Let's call this __cr4_set() instead of update_cr4(). The __ is to remind people that it's not really for use and starting with cr4_ is consistent with the rest of the functions. Also, can you split this whole thing into two patches? The introduction of the separate update function is a great cleanup, but I think it's orthogonal.