On 11/03/17 16:51 +0800, Haozhong Zhang wrote: > On 11/03/17 14:54 +0800, Xiao Guangrong wrote: > > > > > > On 11/03/2017 01:53 PM, Haozhong Zhang wrote: > > > Some reserved pages, such as those from NVDIMM DAX devices, are > > > not for MMIO, and can be mapped with cached memory type for better > > > performance. However, the above check misconceives those pages as > > > MMIO. Because KVM maps MMIO pages with UC memory type, the > > > performance of guest accesses to those pages would be harmed. > > > Therefore, we check the host memory type by lookup_memtype() in > > > addition and only treat UC/UC- pages as MMIO. > > > > > > Signed-off-by: Haozhong Zhang <haozhong.zhang@xxxxxxxxx> > > > Reported-by: Cuevas Escareno, Ivan D <ivan.d.cuevas.escareno@xxxxxxxxx> > > > Reported-by: Kumar, Karthik <karthik.kumar@xxxxxxxxx> > > > --- > > > arch/x86/kvm/mmu.c | 19 ++++++++++++++++++- > > > 1 file changed, 18 insertions(+), 1 deletion(-) > > > > > > diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c > > > index 0b481cc9c725..e9ed0e666a83 100644 > > > --- a/arch/x86/kvm/mmu.c > > > +++ b/arch/x86/kvm/mmu.c > > > @@ -2708,7 +2708,24 @@ static bool mmu_need_write_protect(struct kvm_vcpu *vcpu, gfn_t gfn, > > > static bool kvm_is_mmio_pfn(kvm_pfn_t pfn) > > > { > > > if (pfn_valid(pfn)) > > > - return !is_zero_pfn(pfn) && PageReserved(pfn_to_page(pfn)); > > > + return !is_zero_pfn(pfn) && PageReserved(pfn_to_page(pfn)) && > > > + /* > > > + * Some reserved pages, such as those from > > > + * NVDIMM DAX devices, are not for MMIO, and > > > + * can be mapped with cached memory type for > > > + * better performance. However, the above > > > + * check misconceives those pages as MMIO. > > > + * Because KVM maps MMIO pages with UC memory > > > + * type, the performance of guest accesses to > > > + * those pages would be harmed. Therefore, we > > > + * check the host memory type in addition and > > > + * only treat UC/UC- pages as MMIO. > > > + * > > > + * pat_pfn_is_uc() works only when PAT is enabled, > > > + * so check pat_enabled() as well. > > > + */ > > > + (!pat_enabled() || > > > + pat_pfn_is_uc(kvm_pfn_t_to_pfn_t(pfn))); > > > > Can it be compiled if !CONFIG_PAT? > > Yes. > > What I check via pat_enabled() is not only whether PAT support is > compiled, but also whether PAT is enabled at runtime. > > > > > It would be better if we move pat_enabled out of kvm as well, > > Surely I can combine them in one function like > > bool pat_pfn_is_uc(pfn_t pfn) > { > enum page_cache_mode cm; > > if (!pat_enabled()) > return false; > > cm = lookup_memtype(pfn_t_to_phys(pfn)); > > return cm == _PAGE_CACHE_MODE_UC || cm == _PAGE_CACHE_MODE_UC_MINUS; > } In addition, I think it's better to split this function into pat_pfn_is_uc() and pat_pfn_is_uc_minus() to avoid additional confusion. Haozhong > > but I need a good name to make its semantics clear, or is it enough to > just leave a comment like? > > /* > * Check via PAT whether the cache mode of a page if UC or UC-. > * > * Returns true, if PAT is enabled and the cache mode is UC or UC-. > * Returns false otherwise. > */ > > > > please refer > > to pgprot_writecombine() which is implemented in pat.c and in > > include\asm-generic\pgtable.h: > > > > #ifndef pgprot_writecombine > > #define pgprot_writecombine pgprot_noncached > > #endif > > > > >