On Fri, 17 Mar 2017, Dong Jia Shi wrote: > For future code reuse purpose, this decouples the cio code with > the ccw device specific parts from ccw_device_cancel_halt_clear, > and makes a new common I/O interface named cio_cancel_halt_clear. > > Reviewed-by: Pierre Morel <pmorel@xxxxxxxxxxxxxxxxxx> > Signed-off-by: Dong Jia Shi <bjsdjshi@xxxxxxxxxxxxxxxxxx> > Cc: Sebastian Ott <sebott@xxxxxxxxxxxxxxxxxx> > Cc: Peter Oberparleiter <oberpar@xxxxxxxxxxxxxxxxxx> [...] > +/** > + * cio_cancel_halt_clear - Cancel running I/O by performing cancel, halt > + * and clear ordinally if subchannel is valid. > + * @sch: subchannel on which to perform the cancel_halt_clear operation > + * @iretry: the number of the times remained to retry the next operation > + * > + * This should be called repeatedly since halt/clear are asynchronous > + * operations. We do one try with cio_cancel, two tries with cio_halt, ^ three Acked-by: Sebastian Ott <sebott@xxxxxxxxxxxxxxxxxx>