[kvm-unit-tests PATCH v2 0/4] pci: Various PCI BAR checks

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Andrew,

Here is v2 of the series - it improves BAR validation function and
scatters more calls to that around.

Cc: Thomas Huth <thuth@xxxxxxxxxx>
Cc: Andrew Jones <drjones@xxxxxxxxxx>

Alexander Gordeev (4):
  pci: Rework pci_bar_is_valid()
  pci: Split and rename pci_bar_is_valid() to pci_bar_exists()
  pci: Ensure BAR validity for public functions
  pci: pci-host-generic: Use INVALID_PHYS_ADDR instead of ~0

 lib/pci-host-generic.c |  6 +++---
 lib/pci-testdev.c      |  2 +-
 lib/pci.c              | 35 ++++++++++++++++++++++++++++++++---
 lib/pci.h              |  5 +++++
 x86/vmexit.c           |  2 +-
 5 files changed, 42 insertions(+), 8 deletions(-)

-- 
1.8.3.1




[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux