Changes from v10: * Change the name of loop test function to precise_instrs_loop() * Minor comment fixes to measure_instrs() and to explain isb() in loop funcs Note: 1) Current KVM code has bugs in handling PMCCFILTR write. A fix (see below) is required for this unit testing code to work correctly under KVM mode. https://lists.cs.columbia.edu/pipermail/kvmarm/2016-November/022134.html. Thanks, -Wei Christopher Covington (3): arm: Add PMU test arm: pmu: Check cycle count increases arm: pmu: Add CPI checking arm/Makefile.common | 3 +- arm/pmu.c | 351 ++++++++++++++++++++++++++++++++++++++++++++++++++++ arm/unittests.cfg | 19 +++ 3 files changed, 372 insertions(+), 1 deletion(-) create mode 100644 arm/pmu.c -- 1.8.3.1 -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html