On 11/8/2016 12:59 PM, Alexey Kardashevskiy wrote: > On 05/11/16 08:10, Kirti Wankhede wrote: >> Vendor driver using mediated device framework should use >> vfio_info_add_capability() to add capabilities. >> Introduced this function to reduce code duplication in vendor drivers. >> >> Signed-off-by: Kirti Wankhede <kwankhede@xxxxxxxxxx> >> Signed-off-by: Neo Jia <cjia@xxxxxxxxxx> >> Change-Id: I6fca329fa2291f37a2c859d0bc97574d9e2ce1a6 >> --- >> drivers/vfio/vfio.c | 60 +++++++++++++++++++++++++++++++++++++++++++++++++++- >> include/linux/vfio.h | 3 +++ >> 2 files changed, 62 insertions(+), 1 deletion(-) >> >> diff --git a/drivers/vfio/vfio.c b/drivers/vfio/vfio.c >> index 4ed1a6a247c6..9a03be0942a1 100644 >> --- a/drivers/vfio/vfio.c >> +++ b/drivers/vfio/vfio.c >> @@ -1797,8 +1797,66 @@ void vfio_info_cap_shift(struct vfio_info_cap *caps, size_t offset) >> for (tmp = caps->buf; tmp->next; tmp = (void *)tmp + tmp->next - offset) >> tmp->next += offset; >> } >> -EXPORT_SYMBOL_GPL(vfio_info_cap_shift); >> +EXPORT_SYMBOL(vfio_info_cap_shift); > > > Why this change? > > We want this symbol to be available to all drivers. >> >> +static int sparse_mmap_cap(struct vfio_info_cap *caps, void *cap_type) >> +{ >> + struct vfio_info_cap_header *header; >> + struct vfio_region_info_cap_sparse_mmap *sparse_cap, *sparse = cap_type; >> + size_t size; >> + >> + size = sizeof(*sparse) + sparse->nr_areas * sizeof(*sparse->areas); >> + header = vfio_info_cap_add(caps, size, >> + VFIO_REGION_INFO_CAP_SPARSE_MMAP, 1); >> + if (IS_ERR(header)) >> + return PTR_ERR(header); >> + >> + sparse_cap = container_of(header, >> + struct vfio_region_info_cap_sparse_mmap, header); >> + sparse_cap->nr_areas = sparse->nr_areas; >> + memcpy(sparse_cap->areas, sparse->areas, >> + sparse->nr_areas * sizeof(*sparse->areas)); >> + return 0; >> +} >> + >> +static int region_type_cap(struct vfio_info_cap *caps, void *cap_type) >> +{ >> + struct vfio_info_cap_header *header; >> + struct vfio_region_info_cap_type *type_cap, *cap = cap_type; >> + >> + header = vfio_info_cap_add(caps, sizeof(*cap), >> + VFIO_REGION_INFO_CAP_TYPE, 1); >> + if (IS_ERR(header)) >> + return PTR_ERR(header); >> + >> + type_cap = container_of(header, struct vfio_region_info_cap_type, >> + header); >> + type_cap->type = cap->type; >> + type_cap->subtype = cap->subtype; >> + return 0; >> +} >> + >> +int vfio_info_add_capability(struct vfio_info_cap *caps, int cap_type_id, >> + void *cap_type) >> +{ >> + int ret = -EINVAL; >> + >> + if (!cap_type) >> + return 0; >> + >> + switch (cap_type_id) { >> + case VFIO_REGION_INFO_CAP_SPARSE_MMAP: >> + ret = sparse_mmap_cap(caps, cap_type); >> + break; >> + >> + case VFIO_REGION_INFO_CAP_TYPE: >> + ret = region_type_cap(caps, cap_type); >> + break; >> + } >> + >> + return ret; >> +} >> +EXPORT_SYMBOL(vfio_info_add_capability); >> >> /* >> * Pin a set of guest PFNs and return their associated host PFNs for local >> diff --git a/include/linux/vfio.h b/include/linux/vfio.h >> index dcda8fccefab..cf90393a11e2 100644 >> --- a/include/linux/vfio.h >> +++ b/include/linux/vfio.h >> @@ -113,6 +113,9 @@ extern struct vfio_info_cap_header *vfio_info_cap_add( >> struct vfio_info_cap *caps, size_t size, u16 id, u16 version); >> extern void vfio_info_cap_shift(struct vfio_info_cap *caps, size_t offset); >> >> +extern int vfio_info_add_capability(struct vfio_info_cap *caps, >> + int cap_type_id, void *cap_type); >> + > > > It would make it easier to review and bisect if 14/22 was squashed into > this one. This was split based on Alex's suggestion on earlier version of this patchset. > In the resulting patch, vfio_info_cap_add() can be made static as > it will only be used in drivers/vfio/vfio.c from now. > Not sure that vfio_info_cap_add() should be made static. If there are any other drivers using this symbol outside kernel might break with that change. Thanks, Kirti > > > >> struct pci_dev; >> #ifdef CONFIG_EEH >> extern void vfio_spapr_pci_eeh_open(struct pci_dev *pdev); >> > > -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html