On Tue, Aug 16, 2016 at 11:45:09AM +0100, Punit Agrawal wrote: > From: Mark Rutland <mark.rutland@xxxxxxx> > > As with dsb() and isb(), add a __tbli() helper so that we can avoid Minor typo: s/__tbli/__tlbi/ > distracting asm boilerplate every time we want a TLBI. As some TLBI > operations take an argument while others do not, some pre-processor is > used to handle these two cases with different assembly blocks. > > The existing tlbflush.h code is moved over to use the helper. > > Signed-off-by: Mark Rutland <mark.rutland@xxxxxxx> > Cc: Catalin Marinas <catalin.marinas@xxxxxxx> > Cc: Marc Zyngier <marc.zyngier@xxxxxxx> > Cc: Will Deacon <will.deacon@xxxxxxx> > [ rename helper to __tlbi, update commit log ] > Signed-off-by: Punit Agrawal <punit.agrawal@xxxxxxx> > --- > arch/arm64/include/asm/tlbflush.h | 31 +++++++++++++++++++++++-------- > 1 file changed, 23 insertions(+), 8 deletions(-) > > diff --git a/arch/arm64/include/asm/tlbflush.h b/arch/arm64/include/asm/tlbflush.h > index b460ae2..d57a0be 100644 > --- a/arch/arm64/include/asm/tlbflush.h > +++ b/arch/arm64/include/asm/tlbflush.h > @@ -25,6 +25,21 @@ > #include <asm/cputype.h> > > /* > + * Raw TLBI operations. Drivers and most kernel code should use the TLB > + * management routines below in preference to these. Where necessary, these can > + * be used to avoid asm() boilerplate. > + * > + * Can be used as __tlbi(op) or __tlbi(op, arg), depending on whether a > + * particular TLBI op takes an argument or not. The macros below handle invoking > + * the asm with or without the register argument as appropriate. > + */ > +#define TLBI_0(op, arg) asm ("tlbi " #op) > +#define TLBI_1(op, arg) asm ("tlbi " #op ", %0" : : "r" (arg)) > +#define TLBI_N(op, arg, n, ...) TLBI_##n(op, arg) Should this be prefixed with underscores, too? Will -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html