On Sun, Apr 19, 2009 at 02:54:28PM -0300, Marcelo Tosatti wrote: > I'm fine with your kvm_flush_local_tlb. Just one minor nit: > > + /* get new asid before returning to guest mode */ > + if (!test_bit(KVM_REQ_TLB_FLUSH, &vcpu->requests)) > + set_bit(KVM_REQ_TLB_FLUSH, &vcpu->requests); > > Whats the test_bit for? To avoid a write in case it was already set... but thinking twice I guess the probability that it's already set is near zero, so I'll remove it and I'll just do set_bit. > It was nice to hide explicit knowledge about > vcpu->kvm->remote_tlbs_dirty behind the interface instead of exposing > it. Hmm ok, if you prefer it I'll add it back. I guess ..._tlb_dirty_cond is better name so it's clear it's not just checking the cond but the dirty flag too. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html