Hi all, This series should be applied on top of "Cleanup low-level arch code" series which is still not included. Yet, it is ready for review as all previous comments and suggestions are addressed. There might be some confusion about version numbering as I posted the previous version as RFC with no version number at all. In fact it was 3rd version so I am labelling this series as v4. Unlike the RFC it does not have gaps in implementation. There are quite a lot of changes since the previous version. I tried pci-testdev against ARM and got the device semi-operational. It is still to investigate, but that could be addressed separately. Most interesting - writing to IO BAR on ARM does not seem working as a written value does not read back. Probably, ARM64 is also affected, but again - I have not investigated it yet. Cc: Thomas Huth <thuth@xxxxxxxxxx> Cc: Andrew Jones <drjones@xxxxxxxxxx> Alexander Gordeev (12): pci: Fix coding style in generic PCI files pci: x86: Rename pci_config_read() to pci_config_readl() pci: x86: Add remaining PCI configuration space accessors pci: Rework pci_bar_addr() pci: Factor out pci_bar_get() pci: Add pci_bar_set_addr() pci: Add pci_dev_exists() pci: Add pci_print() pci: Add generic ECAM host support arm/arm64: pci: Add PCI bus operation test pci: Add pci-testdev PCI bus test device arm/arm64: pci: Add pci-testdev PCI device operation test arm/Makefile.common | 7 +- arm/pci-test.c | 31 ++++++ arm/run | 7 +- lib/arm/asm/pci.h | 26 +++++ lib/arm64/asm/pci.h | 1 + lib/pci-host-generic.c | 294 +++++++++++++++++++++++++++++++++++++++++++++++++ lib/pci-host-generic.h | 46 ++++++++ lib/pci-testdev.c | 184 +++++++++++++++++++++++++++++++ lib/pci.c | 194 ++++++++++++++++++++++++++++---- lib/pci.h | 33 +++++- lib/x86/asm/pci.h | 31 +++++- x86/vmexit.c | 4 +- 12 files changed, 830 insertions(+), 28 deletions(-) create mode 100644 arm/pci-test.c create mode 100644 lib/arm/asm/pci.h create mode 100644 lib/arm64/asm/pci.h create mode 100644 lib/pci-host-generic.c create mode 100644 lib/pci-host-generic.h create mode 100644 lib/pci-testdev.c -- 1.8.3.1 -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html