2016-04-07 03:20-0500, Suravee Suthikulpanit: > Adding function pointers in struct kvm_x86_ops for processor-specific > layer to provide hooks for when KVM initialize and un-initialize VM. > > Signed-off-by: Suravee Suthikulpanit <suravee.suthikulpanit@xxxxxxx> > --- > diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c > @@ -7781,6 +7784,9 @@ static void kvm_free_vcpus(struct kvm *kvm) > kvm_for_each_vcpu(i, vcpu, kvm) > kvm_arch_vcpu_free(vcpu); > > + if (kvm_x86_ops->vm_uninit) > + kvm_x86_ops->vm_uninit(kvm); vm_uninit() doesn't seem to have much to do with kvm_free_vcpus(), please call it from kvm_arch_destroy_vm(). (kvm_x86_ops.vm_destroy would be a better name then.) -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html