On 08/03/2016 08:39, Xiao Guangrong wrote: > But i noticed kernel uses the more meaningful name to update > boot_cpu_data.x86_capability[]: > $ git grep x86_capability arch/x86/ > ...... > arch/x86/kernel/cpu/centaur.c: > c->x86_capability[CPUID_C000_0001_EDX] = cpuid_edx(0xC0000001); > arch/x86/kernel/cpu/common.c: c->x86_capability[CPUID_1_ECX] = ecx; > arch/x86/kernel/cpu/common.c: c->x86_capability[CPUID_1_EDX] = edx; > arch/x86/kernel/cpu/common.c: c->x86_capability[CPUID_7_0_EBX] = ebx; > arch/x86/kernel/cpu/common.c: c->x86_capability[CPUID_6_EAX] = cpuid_eax(0x00000006); > arch/x86/kernel/cpu/common.c: c->x86_capability[CPUID_D_1_EAX] = eax; > arch/x86/kernel/cpu/common.c: c->x86_capability[CPUID_F_0_EDX] = edx; > ..... > > Why not follow it in KVM? Oh, indeed. That's fairly new (commit 39c06df4dc10, "x86/cpufeature: Cleanup get_cpu_cap()", 2015-12-07), I had not noticed it. We can change it indeed, but it's probably best to do it only for 4.7. In the meanwhile, for PKRU it's enough to use the right feature number. :) Paolo -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html