Re: [PATCH] KVM: Replace the number of page entries per page with PT64_ENT_PER_PAGE macro

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Sorry. Miss some other modifications and please ignore this version.

On 3/1/2016 10:49 PM, Lan Tianyu wrote:
This patch is to make code more readable.

Signed-off-by: Lan Tianyu <tianyu.lan@xxxxxxxxx>
---
  arch/x86/include/asm/kvm_host.h | 2 +-
  arch/x86/kvm/mmu.c              | 2 +-
  2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h
index 44adbb8..b91a08a 100644
--- a/arch/x86/include/asm/kvm_host.h
+++ b/arch/x86/include/asm/kvm_host.h
@@ -265,7 +265,7 @@ struct kvm_mmu_page {
  	/* The page is obsolete if mmu_valid_gen != kvm->arch.mmu_valid_gen.  */
  	unsigned long mmu_valid_gen;

-	DECLARE_BITMAP(unsync_child_bitmap, 512);
+	DECLARE_BITMAP(unsync_child_bitmap, PT64_ENT_PER_PAGE);

  #ifdef CONFIG_X86_32
  	/*
diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c
index 95a955d..d51441b 100644
--- a/arch/x86/kvm/mmu.c
+++ b/arch/x86/kvm/mmu.c
@@ -1806,7 +1806,7 @@ static int __mmu_unsync_walk(struct kvm_mmu_page *sp,
  {
  	int i, ret, nr_unsync_leaf = 0;

-	for_each_set_bit(i, sp->unsync_child_bitmap, 512) {
+	for_each_set_bit(i, sp->unsync_child_bitmap, PT64_ENT_PER_PAGE) {
  		struct kvm_mmu_page *child;
  		u64 ent = sp->spt[i];


--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux